Jump to content

Launch Problem [Linux]


Recommended Posts

Hello people! 


So starting up the Attack of the B-Team modpack, it downloads all the mods properly but when it reaches the mojang screen and loads for a while it comes up with this: http://pastebin.com/gvMX6Uw8


I noticed that necromancy(1.4c-9) popped up so I removed the file from the .technic folder and started up AotBT again, it loaded up fine no problems but when the necromancy mod was put back in the problem came back, if anyone has a fix to this at all, thank you very much.


P.S Don't forget this is on linux, not windows :) (And please don't just say 'Get windows' I'll just ignore you.)

Edited by Vegetix_
Link to comment
Share on other sites

Follow the link in my sig - you might only have launcher logs, not crash logs - if so then that's fine, but we'll need it anyway.  Did you already make sure your current graphics drivers support opengl properly?


Edit: You can test opengl quickest by running normal minecraft if you haven't - it uses lwjgl just the same so if that works its a good sign that's set up right.

Edited by Loader
Link to comment
Share on other sites

I would like to toss in my experience just now.   My Windows machine got a root kit infection and so I'm on a Dell D630 laptop running Ubuntu 12.04.  Using tekkit launcher I could successfully  launch and play vanilla minecraft and hexxit pack.  But launching AofBteam, downloads/checks mods and then seems to almost launch and pops back to launch screen even before the Majong splash page appears.  I haven't had any time to mess with anything and am not sure where the logs are in this system.   I have to get back to work in a 15min, but afterwards I can look and send logs if  you like.

Link to comment
Share on other sites

Ok, well I just did a fresh install of ubuntu 12.04.   On this machine it has 6 core amd, 8gb memory, running latest JDK6 and 7.   Same thing occurs, click play, loads, launcher momentarily disappears and pops back to launcher screen.     Only happens on attack of b-team mod.    Looked at logs and I see this error


[b#431] 2014/03/25 16:26:56 [iNFO]  2014-03-25 16:26:56 [sEVERE] [ForgeModLoader] An error occurred trying to configure the minecraft home at /home/(PCNAME)/.technic/modpacks/attack-of-the-bteam for Forge Mod Loader.


So is it some kind of rights issue?  The location is correct, just can't do what it needs to.


Any suggestions?   Again, new machine, different hardware, same issue.   just not sure what to do about it.


Link to comment
Share on other sites

Hello everyone!   The fix was simple!


So all I had to do was install Java 7.      Minecraft mods, like forge, have issues with OPEN JDK6 and 7 java that was installed with my linux.  I'm running elementary OS, which is basically ubuntu 12.04.     I did not have to remove Open JDK to get it to work.    I will list the commands I used to install, but please google  for instructions for installing Java 7 if you are running something different then me.


Run commands in a terminal 


(get java repository)

sudo add-apt-repository ppa:webupd8team/java
sudo apt-get update


(install java 7)
sudo apt-get install oracle-java7-installer


(determine your version after install)

java -version


Mine said as of March 26 2014   that it is     java version "1.7.0_51"



I don't know how, but this bit of info should be announced/told to debian community.

Link to comment
Share on other sites

That's strange, thanks for coming back and letting us know - this is the first time I've seen problems like this with openJDK 1.7 (1.6 obviously doesn't work).  I'll bear it in mind for future issues.


Well it is a bit strange, but then Elementary OS and (i think) Ubuntu both run by default OpenJDk 6 as their default java (i installed JDK7 after having issues with launcher, but didn't remove JDK6 thinking other programs might need it, perhaps that might have fixed it as well.  Don't want to mess with it now that its working to test that theory)   But from what I gather reading on the internet, it is not directly supported by JAVA.   Some legal issue it would seem.   So I had a thought that maybe they don't run the same.   I looked a bit around and found couple other people with launch issues in other mods with forge and java, their solution was to remove and reinstall the latest version from Java and that seemed to work.   So I thought why not give that a shot?   Was a fairly simple search to find the install for regular Java and it worked.    


Anyway thanks for help loader!  nice to see a community that works together.

Edited by telocity
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...