Jump to content

Frustrations with the Oil Fabricator


Recommended Posts

I have watched many a videos and such about them. Most lean towards Solar Panels as the best method for powering them. I've tried that to utter failure. I've tried some Combustion Engines. I've tried Steam Turbines with a brutally massive boiler. 


The problem I am having is that it NEVER puts out oil. The energy bar fills up. The idle bar fills up. The work bar never does... Anything. And it never produces a drop of oil.


I have tried in a survival server and in solo casual. We just downloaded Tekkit two days ago and the only change we made was adding Railcraft. One drag and drop mod added in. 

Link to comment
Share on other sites

I went into Creative, put down a Oil Fabricator next to a Creative Energy Cell, and it worked fine. See if you can replicate this. If you can, it might be a problem with your ingame setup; if not, it might be introduced by Railcraft.


What are you using the oil for, anyway?

Link to comment
Share on other sites

Why anybody would want to turn energy into oil with the (over-)abundance of oil reservoirs is beyond me, but all machines in Tekkit should work nonetheless, and there are surely some use cases for it.

I put an Oil Fabricator in my generator room, fluiducted it to the main oil tank and it started just fine. The tooltip says that it will accept RF, MJ and even EU input (RF in my case) and it draws quite a lot of power. Running from a resonant energy cell here.


Did you always hook up the energy producers right to the fabricator? Maybe try to put an energy cell in between, preferably redstone-level. Maybe you just didn't supply enough energy for it to start.

Otherwise, try doing it without Railcraft installed.

Edited by Curunir
Link to comment
Share on other sites

Well I got that problem ironed out. One of the tutorials I read made mention of a need for a redstone signal which actually activates the idle mode or something.


On the other hand the massive number of conflicting items in this cluster of mods is causing me massive frustration. The brutal lack of consistent documentation is causing even more frustration. I am going to go ahead and uninstall this package and wait for some additional fixes to come along.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...