Jump to content

Tekkit and Multicraft control panel

Recommended Posts

I'm still working on it. Multicraft uses Jars from one folder and puts on the server files in another folder.

Right now when I try starting it up with a tekkit jar I get this...

java.io.IOException: Permission denied

at java.io.UnixFileSystem.createFileExclusively(Native Method)

at java.io.File.createNewFile(File.java:900)

at net.minecraft.server.ModLoader.init(ModLoader.java:542)

at net.minecraft.server.ModLoader.Init(ModLoader.java:1082)

at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:100)

at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:402)

at net.minecraft.server.ThreadServerApplication.run(SourceFile:457)

Link to comment
Share on other sites

Does anyone have any experience with the control panel Called Multicraft.

I an using a VPS running Centos that has Multicraft installed and due to the way it handles Jar files I'm not sure how to get Tekkit up and running on the server.

I'm not a user of CentOs, but that sounds like you have permissions incorrectly setup...

I'm using;

Ubuntu 11.10 Server x64

McMyAdmin Personal

Tekkit 1.1.4

Craftbukkit 1.0.1

all i done to get Tekkit started was to rename the Tekkit "Server" Jar to craftbukkit.jar

Link to comment
Share on other sites

Just been digging around, and found this...

I ran into this problem recently and found that java.io.File.createNewFile() actually requires the "Change Permissions" permission (you can find this entry under Security->Advanced when checking folder permissions). Without this it will create the file and then subsequently throw an IOException.

It's deceptive because you will still be able to create files on the folder when manually testing, however createNewFile() will still fail if it doesn't have this particular permission (presumably such that it can change the permissions on the file its creating).

I have no idea what it means, as i use Ubuntu, i just use chmod on the folder

Link to comment
Share on other sites

The problem is ModLoader trying to make a configuration and/or log file. Whatever it is, ModLoader tells Java to create a file and write in it. Java tells the system, but the system claims that Java's permissions have been denied. Try running as administrator, and make sure that the permissions for the folder are open, some OSs will lock any new folders by default.

Link to comment
Share on other sites

I finally got it up and running solid.

You have to set the option of "Look for JARs in" to "Server JAR directory"

Then make a copy of the craft_bukkit.jar.conf. Rename it to Tekkit.jar.conf and edit it for Tekkit instead of Craftbuckett.

Working like a champ now....now I just need Tekkit 2.0 and I will finally be all done.

Thanks for the help and I also got great support from MultiCraft Customer Service.

Link to comment
Share on other sites

  • 2 months later...

Just install Tekkit and all the config files in the /home/minecraft/multicraft/jar directory. Copy the config file over from Bukkit. Make sure the permissions allow it all to run... and also put all the plugin/config files are ALSO in the users server directory. The redundancy of the files is key.

Works like a charm after that :D

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...