Jump to content

Very strange server lag

Recommended Posts

Hey guys, wondering if you can wrap your heads around this. I've gone at it every angle I can think of/find info about and nothing has worked.

I have a very odd type of lag on my client. I've determined it's my client only, not my user, but my computer. In and around my Tekkit Lab with all of my machines it's FINE, no problems at all, runs like it should. But when I leave this area, the game lags out to hell. We're talking <5FPS max. The lag will disappear if I return to my base but will return if I leave again. It's odd, as I can find certain lines that make huge lags spikes if I step over them.

Strangely, if I close my client (not just disconnect/reconnect) and restart it this will fix it momentarily for the chunk I am in. Say I disconnect in a laggy area and reconnect, that laggy area will run perfectly fine as long as I don't leave it, then the previous symptoms will return.

In another twist, I found that in trying to fix this problem deleting the .minecraft and .techniclauncher folders from appdata stopped the problem for the first time I logged in only. The next time I logged in I was back a square one.

There has been lag on the server before, but it was never this persistent or detrimental to my gameplay.

Now, to save you a bit of time, unsuccessful things I have tried:

restarting - duh

starting a new server and replacing on the world files

disabling the computercraft mod to eliminate my shoddy coding

uninstalling/reinstalling Java (currently running 64 bit version 7 update 4, one update ahead of server)

removing some redstone (use of redstone on server is minimal, and near the lab, so I'm stumped, there are a few wireless redstone transmitters)

/remove items -1 using worldedit or worldguard, whichever - we did have a problem with a transmutation tablet that dropped items in the area I'm currently trying to build in

Please, any ideas, as I'm all out...

Link to comment
Share on other sites

turn your sound off and see if that helps. there's a known issue with IC2 (possibly just the advanced machines?) and their sound effects. you could also edit the IC2 config to disable sounds from IC2 machines only.

Link to comment
Share on other sites

Is it just you getting lagged out in certain areas or is it everyone on the server?

Also are you getting lag no matter which direction you head out from your "lab" or just one way?

Since you said there are lines you can cross that cause the problem it might be that you are lagging when a certain chunk is loaded by your view distance. It might be worth walking into the area you are getting lag and typing "/debug clock" (without ""). It's a commandbook command that'll check how long it takes for the server to complete 20 ticks. That should at least help determine if it's you or the server struggling.

Link to comment
Share on other sites

I tried it today and I was unable to recreate the error. This is very strange, not unwelcome though, I just hope that it doesn't return.

In response to your question it was only me who had problems with lagging in certain areas. If I do come across lag like that again I can test whether the lag disappears if I trek far enough away. I did have problems in all directions when I left my lab

No difference with or without sound, still works. Does it layer up or something along those lines? If I turned off my sound a moment then re-enabled it could that have fixed the lag?

And debug clock comes to 19.9 ticks out of 20 expected ticks. Close enough, no?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...