Jump to content

Destruction Catalyst usage causing IllegalArgumentException


Recommended Posts

Running a standard install of Tekkit 3.0.3 server, my roommates and I are connecting via the launcher exe.

Upon my roomate using the Destruction Catalyst EE item, and picking up the little ball that's supposed to contain all the items, my server spits out this message:

14:42:42 [WARNING] Failed to handle packet: java.lang.IllegalArgumentException:

Can't create an EntityItem for a null item

java.lang.IllegalArgumentException: Can't create an EntityItem for a null item

    at net.minecraft.server.EntityItem.<init>(EntityItem.java:29)

    at ee.core.PickupHandler.onItemPickup(PickupHandler.java:29)

    at forge.ForgeHooks.onItemPickup(ForgeHooks.java:165)

    at net.minecraft.server.EntityItem.a_(EntityItem.java:166)

    at net.minecraft.server.EntityHuman.l(EntityHuman.java:363)

    at net.minecraft.server.EntityHuman.e(EntityHuman.java:355)

    at net.minecraft.server.EntityLiving.F_(EntityLiving.java:447)

    at net.minecraft.server.EntityHuman.F_(EntityHuman.java:168)

    at net.minecraft.server.EntityPlayer.a(EntityPlayer.java:233)

    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:375)

    at net.minecraft.server.Packet10Flying.handle(SourceFile:126)

    at net.minecraft.server.NetworkManager.b(NetworkManager.java:234)

    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:121)

    at net.minecraft.server.NetworkListenThread.a(NetworkListenThread.java:78)

    at net.minecraft.server.MinecraftServer.w(MinecraftServer.java:556)

    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:453)

    at net.minecraft.server.ThreadServerApplication.run(SourceFile:492)

Then the server gives an internal server error, and disconnects him. Any attempt to re-connect to the server prompts the same error string in my server console, and boots him again. I've tried restarting the server, but nothing's keeping it from auto-booting him every time he tries to connect.

We figured it might be some error with an item that was put in his inventory, but I'm not sure how to remotely remove a glitched item from a players' inventory, server-side.

Any help with this bug would be much appreciated!

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...