Jump to content

Model Issues


Recommended Posts

Hello all!


 I don't know if I'm the only one or not, but in Ubuntu 12.04 (With the latest HWE's enabled) running the recommended version of Tekkit Main, I have ran into a lot of missing models (I don't have a example screenshot on hand), and the most obvious of these would be bits of chests missing, and torsos of mobs/players missing. It appears to only happen to blocks with models as anything else is fine. As far as I know this is only a Ubuntu thing as my friend on Windows 7 ran into no issues.

 Now with the explanation out of the way, how would I go about fixing this issue? Any and all advice is helpful. Thanks.

 (If I managed to put this in the wrong forum, let me know, Ill move it.)

Link to comment
Share on other sites

Open JRE version ? tried installing a official java pack from oracle for ubuntu and running it via that java 1.7 version ? That might do the trick, could be due to that version of java.


Could also be due to OpenGL issue, or a graphics driver issue, worth checking those out as well to see if latest for ubuntu and working well.


For example tried other opengl games under linux and those worked well ? if those also have an issue with drawing, try finding a better graphics driver.


(For example nvidia driver package can be downloaded for ubuntu from the nvidia site, etc. as linux distros may not ship it directly nor host it in it's update system if I am correct.)

Edited by Gigeran
Link to comment
Share on other sites

Sounds like graphics driver. In case you are not using the manufacturer's binary blob, maybe that causes the issue. Free drivers have come a long way, but they are never error-free.

Apart from that, you can always reset the modpack and see if you just had local file corruptions. As for Java, the recommended environment for Tekkit is Java 7 64bit, which is currently at update 71.


If none of these is the cause, or if you have further questions, please take your issue to the tracker. You probably should add a screenshot or two, so we have a chance to look at the problem.

Link to comment
Share on other sites

 Thanks for the quick reply. 

 Open JDK (That is JRE) is 7. I also have 6 installed, and when ran under that it does the same.

 There used to be properiety drivers (graphics card drivers), but once I installed the HWE they kind of *waves hand in sweeping motion* disappeared. No idea where they went. In fact, that was about the time when my issues started.

 Im currently installing fglrx in hopes of fixing this.

Link to comment
Share on other sites

 Curunir, I was in the middle of replying to you when fglrx-updates finished installation, and lo and behold, my proprietary drivers! That should be the issue fixed, I'm starting Tekkit now.

 Wish me luck.

Edited by rbuxton1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...