Archived

This topic is now archived and is closed to further replies.

dylliewillie

Failed to bind to port.

14 posts in this topic

Hey

I'm trying to run my own tekkit server with hamachi but I cant get it to work.

Me and my friend both got the same problem:

16:53:51 [iNFO] Starting minecraft server version 1.1

16:53:51 [iNFO] Loading properties

16:53:51 [iNFO] Starting Minecraft server on 5.18.7.247:25565

16:53:51 [WARNING] **** FAILED TO BIND TO PORT!

16:53:51 [WARNING] The exception was: java.net.BindException: Cannot assign requ

ested address: JVM_Bind

16:53:51 [WARNING] Perhaps a server is already running on that port?

>


I tried many things

- Updated java6 to java7

- Changed server.properties with adding port & ip 

- Stopping java.exe or javaw.exe is not working

- Searched on google & these forums

- Did some things from the stickied topic's 



I can still run my bukkit server but not the tekkit server :/

My other friend just double clicked launch.bat and it worked for him, I dont understand why it cant bind to the port...



(also after the port error I get another error like this)


16:53:59 [sEVERE] Exception in thread "WirelessRedstoneUpdaterThread"

16:54:21 [sEVERE] java.lang.IndexOutOfBoundsException: Index: 0, Size: 0

16:54:21 [sEVERE]    at java.util.ArrayList.rangeCheck(Unknown Source)

16:54:21 [sEVERE]    at java.util.ArrayList.get(Unknown Source)

16:54:21 [sEVERE]    at net.minecraft.server.PacketHandlerRedstoneWireless$Pa

cketHandlerOutput.sendEtherTilesToAll(PacketHandlerRedstoneWireless.java:168)

16:54:21 [sEVERE]    at net.minecraft.server.mod_WirelessRedstone$1.run(mod_W

irelessRedstone.java:74)

16:54:21 [sEVERE]    at java.lang.Thread.run(Unknown Source)

>

If you can please help me

(sorry for bad English I'm dutch:P)

Share this post


Link to post
Share on other sites

I had a similar problem to you at first. I don't know enough to properly troubleshoot java, but I can suggest a temporary workaround that helped me.

Change the port in the server.properties file by one or two down (eg, ending in 4 instead of the default), do the same with your port forwarding. Mine works ok for me now, but that worked for me (until it randomly started working properly.

That might help until someone more knowledgeable can step in to help.

Share this post


Link to post
Share on other sites

Thank you for the quick repose

But I don't think this is working for me because I don't know anything about port forwarding because I use hamachi...

Thanks anyways ;)

Share this post


Link to post
Share on other sites

If you get this problem, then you already have something using that port. It's probably a minecraft server, and you may not have stopped the server properly when you last closed it.

Save and close your client.

On windows, press CTRL, SHIFT and ESC, then click "processes".

Close anything that is called java.exe or javaw.exe.

Share this post


Link to post
Share on other sites

Nope Im not running anything on that port + I already said that stopping java.exe or javaw.exe is NOT the problem...

Share this post


Link to post
Share on other sites

Obviously something IS blocking that port, else it would work. Or, like mentioned above, your firewall/router blocks the output.

http://portforward.com/ could help, also when you use hamachi.

It almost can't be anything else. If you really dont know what it is, then well, perhaps is a trojan holding up this port ;)

Really, what else should it be.

Can't imagine anything else.

Share this post


Link to post
Share on other sites

as other people have said, it's a very specific error with a very specific cause. the port is already in use. the most likely candidate is another minecraft server. go into server.properties and change the port by 1 or 2 as was suggested earlier. don't worry about forwarding, since you have hamachi set up. see if that works.

Share this post


Link to post
Share on other sites

as other people have said, it's a very specific error with a very specific cause. the port is already in use. the most likely candidate is another minecraft server. go into server.properties and change the port by 1 or 2 as was suggested earlier. don't worry about forwarding, since you have hamachi set up. see if that works.

Changing port by 1 or 2 up or down is both not working still can't bind to port.

And yeah I got a other server (bukkit) with still works fine on that port but even when Its completely turned off I still cant run my tekkit server :/

Share this post


Link to post
Share on other sites

if it can't bind to any port, than you have something blocking it from listening for incoming traffic. likely candidates are firewalls, firewalls, antivirus programs with firewalls, and firewalls.

Share this post


Link to post
Share on other sites

if it can't bind to any port, than you have something blocking it from listening for incoming traffic. likely candidates are firewalls, firewalls, antivirus programs with firewalls, and firewalls.

Already tried to turn off firewall, anti virus (I got avast!)

Both I did not work also not with 1 or 2 port higher or lower...

Nothing works :[

Share this post


Link to post
Share on other sites

If you get this problem, then you already have something using that port. It's probably a minecraft server, and you may not have stopped the server properly when you last closed it.

Save and close your client.

On windows, press CTRL, SHIFT and ESC, then click "processes".

Close anything that is called java.exe or javaw.exe.

This worked for me but you need to go to processes or something to close the java/javaw things

Share this post


Link to post
Share on other sites

I have found that if you have recenly changed hamachi. Like reinstaled, you need to change your ip to the one on the new hamachi into the propeties file where it says ip and then refresh your server and i shud work.

 

Share this post


Link to post
Share on other sites