Jump to content

Miner not working


Recommended Posts

I'm using Grief Prevention and PermissionsEx.

I remember when I had Towny I had to add fake users [industrialCraft], [buildCraft] and [RedPower] to the permissions list and make a group giving them full power. I've done that and still can't get it to work, I tried adding [industrialcraft] as a server operator and it worked but only temporarily. After restarting the server it stopped working again and now I can't get it work regardless if its an operator or on the permissions file.

No error in console, the miner is drawing power it's just not drilling. Any help is appreciated.

EDIT: Think I found a solution in this thread, http://forums.technicpack.net/threads/ic²-miner-not-mining.11529/#post-108816

EDIT 2: Nope, PermissionsEx 1.19.1 has no change. Issue still stands.

EDIT 3: I've narrowed the issue down to the Grief Prevention plugin.

Link to comment
Share on other sites

  • 2 months later...

i have had the same problem. but finally found a solution.

this is in the PermisssionsEx permissions like, btw.

i added a new user group like so;

Craft:

prefix: '&0(&8craft&0)&7 '

permissions:

- modifyworld.*

- essentials.*

options:

rank: '892'

inheritance:

- Member

then added the fake users like so;

BuildCraft:

group:

- Craft

IndustrialCraft:

group:

- Craft

RedPower:

group:

- Craft

ComputerCraft:

group:

- Craft

ComputerCraft Turtle 0:

group:

- Craft

ComputerCraft Turtle 1:

group:

- Craft

Link to comment
Share on other sites

In the griefprevention config where it says:

PlayersIgnoringAllClaims: []

Make it say this:

PlayersIgnoringAllClaims:

- [industrialCraft]

- [buildCraft]

- [ComputerCraft]

- [RedPower]

Also add any other mods you want to that modify blocks

EDIT: didnt notice it was a necro, sorry. welp at least I gave a solution :P

EDIT EDIT: Also, JB5463 that is not his problem, It is related to griefprevention which doesnt let ops or players with all permissions bypass claims unless they type /ignoreclaims or are in the config

Link to comment
Share on other sites

In the griefprevention config where it says:

PlayersIgnoringAllClaims: []

Make it say this:

PlayersIgnoringAllClaims:

- [industrialCraft]

- [buildCraft]

- [ComputerCraft]

- [RedPower]

Also add any other mods you want to that modify blocks

EDIT: didnt notice it was a necro, sorry. welp at least I gave a solution :P

Not that he needed a solution... (He fixed it himself)

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...