Jump to content

Tekkit 3.0.4 on hosted server - cannot connect

Recommended Posts

Hi all, good morning -

My first post here, and I'm afraid it's already one to ask for help. I've had a Minecraft Vanilla server for about a year now, hosted at www.i3d.nl. Over the last week, we've tried to install the Tekkit 3.0.4 mod on this server, without any luck.

Using the technic pack launcher with tekkit selected at the start, we keep running into the server not being displayed as online on the multiplayer list, while the i3d-control panel tells me my server should be up and running. As we've been following YouTube tutorials on how to install it, and redid the whole process a few times to be sure we've not missed a step, we're now officially stumped by what's the cause of this.

These are the steps we followed;

1) Backed-up the full Vanilla install using FTP.

2) Stopped the server using the i3d control panel.

3) Uploaded the contents of Tekkit_Server_3.0.4.zip except for launch.bat and launch.sh into the root folder using FTP.

4) Deleted the old "Minecraft_Server.exe" file, and renamed Tekkit.jar into Minecraft_Server.exe

5) Restarted the server through the i3d control panel.

At this point the control panel will tell us the server is online, but we are not able to connect to it.

I'm not very tech savvy, but something that seemed a bit strange to me (although i do not know if this matters) is that I didn't see any new files being generated when I refressed the file list using my ftp program. Unlike the installs I see people make using the launch files for a Hamachi-server, there weren't created any new files on the hosted server.

Any suggestions or advice on how to solve this?

Thanks all,



Link to comment
Share on other sites

Hi guys -

an update on this. The issue is still there, though browsing the forums there's a few things I tried out and which I hope will give the more tech savvy people around here an idea about what could be causing this.

- When I put my back-up of the Vanilla install back, everything works perfect.

- Checking the server using ping.eu showed that when Vanilla is installed, port 25595 is open - the moment I put the Tekkit package on there and I rename tekkit.jar to Minecraft_Server.exe this port closes. It doesn't make sense to me, but I do hope it does to someone around here.

Thanks again.

Link to comment
Share on other sites

the reason it isn't working is cause you named the tekkit.jar (jar means java archive) to minecraft_server.exe (windows executable, packaged differently to jars) and the server 'thinks' it's active but in reality it's just 'displaying' an error. Ask your hosting company if they allow modded servers or not. if not then you're gonna have to change hosting provider because renaming it clearly is yealding errors.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...