Jump to content

Extreme Tekkit world errors.

Recommended Posts

Ok, first off, I wasn't sure if it should go in bugs or in General Tekkit, but it didn't really seem like a bug to me.

List of what's been happening:

-Chest resets. It has happened with both alchemical and Crystal chests. My friend emptied most of his inventory into a Alchemical chest, and then a few days later asked me if I had taken, becuase it was gone. I hadn't and was very confused. (The log said we were the only ones who had played in that time period) Later, I emptied all my extra crap into a Crystal chest to make room for mob grinder materials, and about an hour later when I re-surfaced, it was totally empty, again I checked the log, even though it was obvious in chat I was the only one playing at the time.

-Chunk resets, sort of. So we were building a factory and a quarry, ect. and we had a MFE hooked up to an Energy Link and Energy Teleport pipes. Thee, suddenly I looked in the MFE and it was totally empty of power, and reset with the output side facing downwards, upon going upstairs, my friend found his Batbox, Electric Furnace, Generator, etc. were all reset and facing downwards.

Another example of this is I was fixing some creeper holes around our farm perimeter, and then, before my eyes roughly half of the farm just uprooted and turned all the tilled ground to dirt. I collected all the materials, and after I had put them in a chest I looked at the farm again, and there was tall grass on it, even where there was dirt, where it won't place.

-Regenerating volcanoes. Every time the chunks unload or the server restarts. There is a volcano in the desert near where we were building, and I was walking by it and noticed the Big Tree on top of it was gone, and upon closer investigation, the checkerboard we had made on top of it was gone too. I quickly ran around to the other side and realized: the volcano had completely regenerated, deleting the house a player had built in it. I tried restarting the server to see if it would fix the problem, but to my surprise, the volcano was totally gone! I restarted again, and the volcano was back, with me stuck inside of it. I had a player tell me that a volcano generated directly in front of him once, but I just figured it didn't render properly since he lived on the other side of the world, and the volcanoes are glitchy enough in the first place.

-Random "lines" of different biomes going straight through other biomes. THere is a jungle near on of our factory setups, and a few days ago I noticed something very strange: there was a perfect line going through the jungle where not a single tree was. perfectly vertical sides, complete with halved trees. I took a closer look and I noticed that while the trees got deleted, there were some random floating vines, and the ground seemed to be intact and generated normally.

-Being totally unable to build in certain areas, because they reset when the chunks unload or there is a server restart. We were building our main factory building, and my friend complained that he couldn't build in a certain spot because every time he re-logged, the blocks were gone and it was regenerated. I tried building there after he had left, then re-logged, and sure enough, everything I had placed along certain lines were gone. I noticed the very corner of the area had the co-ordinates 0,0 so I thought maybe it was some sort of spawn protection in Bukkit. Spawn is actually quite far away from there, even when the world first generated and we moved spawn slightly.

This is very near the areas of screwed up jungle, magic farm and the disappearing volcano. The only one that was quite a distance from these was the machine reset and the Crystal chest inventory deletion.

Here are some videos I made of them. Please note they aren't at very high quality because I really didn't want to wait for them to upload, and I sped them up, because the picture play speed was very slow. Also, FRAPS screwed up what it recorded in certain points for no apparent reason, so there are just total black spots. It would probably better and more informative to you if you just skimmed through the videos and saw what was generally happening.

Also, it is only a few volcanoes on the server that do this. I have my main house in a volcano and it has been perfectly fine except for that part where all the machines got reset.


Thanks for any help, a list of plugins we are using is below.



Essentials (Including chat and spawn)



SWatchdog, Tekkit edition


All of these should be up to date, I re-downloaded all of them about a week ago to find out which wasn't compatible with Tekkit. (I deleted it, it was IPLock) Our permissions are just using Bukkit.

The world download can be found here:

And my permissions are here, though I don't know why they would screw anything up.

ALSO: I can upload the .jar if you think it is the problem, but I downloaded a fresh one and ran the map on my computer when I recorded the videos, so I'm pretty sure it was the world.

Again, thanks for all of your help, sorry if this isn't in the right forum, but it just doesn't seem like a "bug" to me.

Well I believe all spelling errors are gone, but I'm a bit tired right now so please forgive me for any that are still there...

Link to comment
Share on other sites

ERMAGHERD! I'LL BET IT IS! Better install SuperAntiHerobrine!! Wait... Where do I find the download again? Ugh. I keep forgetting the link to it...

But legitimately, I ran Chunkster, and and it just said "Starting Scan" "press any key to continue..." It said it will show itself fixing chunks, so I'm assuming it either didn't work or didn't find any corrupt chunks...

Link to comment
Share on other sites

  • 2 months later...

you have forgotten one of the worst chunk reset bug of tekkit. I just encountered it on our multiplayer server. i had a machine room downstairs of my house and a chunk have reset RIGHT THROW my machine rooms, refilled everything with cobble dirt, the original chnk has reset, i lost all my machines and some full chests. By the way i think this is the most extreme bug of tekkit

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...