Jump to content

Experiencing a problem with 2.1.1 Server (Telling me I don't have the mods)

Recommended Posts

I just read a topic with the same problem and someone said to delete ModLoader.txt on client+server but that hasn't worked.

So far I have tried it with a completely clean client + server, I deleted all the files for Tekkit and ran a new server.

When I join I get a message telling me:

[img width=500]

Yet on my server console I am seeing a message that says:

<timestamp>[iNFO] Southclaw joined with mod_ModLoaderMp 1.1v4,


mod_NotEnoughItems 1.1.1,

mod_ReiMinimap v3.0_01 [1.1],

mod_BuildCraftCore 2.2.12,

mod_BuildCraftBuilders 2.2.12,

mod_BuildCraftEnergy 2.2.12,

mod_BuildCraftFactory 2.2.12,

mod_BuildCraftTransport 2.2.12,

mod_IC2 v1.70,

mod_PowerConverters 1.1.0R1.3.1,

mod_RedPowerArray 2.0pr4d,

mod_RedPowerCore 2.0pr4d,

mod_RedPowerLighting 2.0pr4d,

mod_RedPowerLogic 2.0pr4d,

mod_RedPowerMachine 2.0pr4d,

mod_RedPowerWiring 2.0pr4d,

mod_RedPowerWorld 2.0pr4d,

mod_Clevercraft 1.6.2,

mod_ItemDescriptions 1.3,

mod_EnderChest 1.0.1,


mod_zAdditionalPipes Rev32.3,

mod_ComputerCraft 1.21,

mod_EE EE2 v1.0.0,

mod_EE EE2 v1.0.0,

mod_InvTweaks 1.38 (1.1),

mod_MAtmos_forModLoader r10 for 1.1.x,

mod_NetherOres 1.1.0R1.1.2,

mod_RailcraftAutomation 3.3.1,

mod_RailcraftBuildcraft 3.3.1,

mod_RailcraftCore 3.3.1,

mod_RailcraftExtras 3.3.1,

mod_RailcraftFactory 3.3.1,

mod_RailcraftIC2 3.3.1,

mod_RailcraftInfrastructure 3.3.1,

mod_RailcraftRails 3.3.1

I know it's pretty pointless posting all of it but I know it is telling me I am joining with the correct mods (I haven't read the list word for word but nothing seems to be missing...)

The versions numbers should be right, I auto updated my client with the launcher, and the server I downloaded the new one and put it in a new folder with a new map to test (2.1.1 right?)

Nothing has changed in my computer dependency-wise (Java version is the same, I haven't changed OS (Win7) and I haven't edited anything) since it last worked (2.0)

So all this points to 2.1.1 being incompatible in some way, I don't know if anyone else has this problem but I'd really like to start playing Tekkit again (Vanilla is getting boring again which I only switched to because of all the updates from Mojang)

Btw I really hope my code is wrapped when I post because it's not in preview mode!

If not I'll add a newline at appropriate places :P

> It didn't wrap, added newlines :)

Link to comment
Share on other sites

Make sure you actually have the 2.1 client version selected in the launcher. Even if you selected it before, removing certain files will reset it back to the default recommended build, which would give you those version mismatches (note that your screenshot shows it wants IC2 1.71, but the log shows you're connecting with 1.70).

Link to comment
Share on other sites

  • 3 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...