Jump to content
  • 0
Sign in to follow this  
Ragnar Homsar

"You do not have the following mods installed" FIX (pictures!)

Question

So you're trying to connect to a Tekkit 2.1 server but keep getting disconnected with a "You do not have the following mods installed:" error. Could the Technic Team have pushed out a server update but forgot to update the client?

No, that doesn't happen and you're an idiot if you think that. The real cause of this issue is the launcher defaults to "Always use Recommended build", in this case, Tekkit 2.0. What we want it to do is always use the latest version. Here's how, in three simple steps!

1:

tut1.png

2:

tut2.png

3:

tut3.png

Share this post


Link to post
Share on other sites

10 answers to this question

Recommended Posts

  • 0

Launcher_dlfailed.png It give me that even thought I retried often,with even deleting the whole .techniclauncher folder

despite this being a bit of a thread hijack......

out of 8 players and myself (myself having tested w/WinXP, win7 64bit, ubuntu 11.10 64bit, xubuntu 11.04 32bit, gentoo 64bit and sabayon8 64bit) 1 of us had this very same issue. no matter what was deleted, cleared, reset, copied or reinstalled, it would fail at 3, 5 or 28%, every time. Finally just rar'ed the whole .technicpack/tekkit(v2.1) folder and sent it to him, and despite him setting it to use 2.1, it would ask to update. if he said yes, it would fail at 5%. If he said no, it let him connect to our server just fine. I have no idea what the cause could be, I couldn't replicate it across 6 OS's on 4 different machines locally.

Share this post


Link to post
Share on other sites
  • 0

what do i do if i am running a mac version of the server and it gives me this bug? I cant download java 7 for a mac yet so any solutions besides stay back at 2.0?

Share this post


Link to post
Share on other sites
  • 0

Hello.

First time posting, so please be gentle with me!

I did as ragnar said, and the launcher asked me to update.

I told it not to, like Krystofer said.

But it doesn't work! it tells me i've got even more mods missing! HEEEEEEEEEEEEEEELP!

(For technical information i can say i havn't got much RAM. Just 2gb i'm afraid :-[. dunno if that fucks things up?)

Share this post


Link to post
Share on other sites
  • 0

what do i do if i am running a mac version of the server and it gives me this bug? I cant download java 7 for a mac yet so any solutions besides stay back at 2.0?

I don't think you need java 7 because it worked fine for me and I don't have java 7.

Share this post


Link to post
Share on other sites
  • 0

This is half related to the launcher,in fact I posted about the very same bug with spoutcraft launcher,(but there was way more visual bug) I was answered the following :

"Something is either blocking downloads through the launcher or Java in general. Likely the first though, as there tends to be issues with programs such as AVG especially. Make sure you add exceptions to any security software you use and try again as that is the only cause of it."

As for other people,first try to update to latest build first,and THEN only if you have the download failed issue,should you start about :

1 Tinkering a bit in you Anti Virus setting,as Nano Saber said,I appear to have AVG,this might cause the issue.But I didnt update it recently,and this bug occured out of nowhere.The only change that I had made prior to this issue is :

Updating to Java 7u3 (that is not responsible for this issue)

All it did,is fix my Tekkit server for 2.1.1 .

The only way I found around this is downloading a fully updated 2.1 " .techniclauncher " folder from a friend.That didnt fix the issue,but at least I could play the 2.1.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...