Sign in to follow this  
Jelato Foot

3.1.3 Reported issues and possible fixes

Recommended Posts

C:\My Documents\Minecraft\Servers\Tekkit J,H,J>java -Xmx4G -Xms4G -jar Tekkit.ja

r nogui

182 recipes

27 achievements

17:47:35 [iNFO] Starting minecraft server version 1.2.5

17:47:35 [iNFO] Attempting early MinecraftForge initialization

17:47:35 [iNFO] Completed early MinecraftForge initialization

17:47:35 [iNFO] Forge Mod Loader version 2.2.91.182 for Minecraft 1.2.5 loading

17:47:35 [iNFO] Loading mods from C:\My Documents\Minecraft\Servers\Tekkit J,H,J

\mods

17:47:35 [WARNING] Failed to load mod class net/minecraft/server/mod_NetherOres.

class in C:\My Documents\Minecraft\Servers\Tekkit J,H,J\mods\mod_NetherOres.jar

17:47:35 [sEVERE] Zip file mod_NetherOres.jar failed to read properly

17:47:35 [iNFO] File mod_NetherOres.jar contained no mods

17:47:36 [iNFO] Directory weaponmod contained no mods

17:47:36 [sEVERE] A problem has occured during mod loading. Likely a corrupt jar

is located in your mods directory

17:47:36 [sEVERE] cpw.mods.fml.common.LoaderException: cpw.mods.fml.common.Loade

rException: java.lang.UnsupportedClassVersionError: net/minecraft/server/mod_Net

herOres : Unsupported major.minor version 51.0

17:47:36 [sEVERE] at cpw.mods.fml.common.Loader.load(Loader.java:436)

17:47:36 [sEVERE] at cpw.mods.fml.common.Loader.loadMods(Loader.java:606)

17:47:36 [sEVERE] at cpw.mods.fml.server.FMLBukkitHandler.onPreLoad(FMLBuk

kitHandler.java:134)

17:47:36 [sEVERE] at net.minecraft.server.MinecraftServer.init(MinecraftSe

rver.java:125)

17:47:36 [sEVERE] at net.minecraft.server.MinecraftServer.run(MinecraftSer

ver.java:428)

17:47:36 [sEVERE] at net.minecraft.server.ThreadServerApplication.run(Sour

ceFile:492)

17:47:36 [sEVERE] Caused by: cpw.mods.fml.common.LoaderException: java.lang.Unsu

pportedClassVersionError: net/minecraft/server/mod_NetherOres : Unsupported majo

r.minor version 51.0

17:47:36 [sEVERE] at cpw.mods.fml.common.Loader.loadModClass(Loader.java:5

27)

17:47:36 [sEVERE] at cpw.mods.fml.common.Loader.attemptFileLoad(Loader.jav

a:562)

17:47:36 [sEVERE] at cpw.mods.fml.common.Loader.load(Loader.java:419)

17:47:36 [sEVERE] ... 5 more

17:47:36 [sEVERE] Caused by: java.lang.UnsupportedClassVersionError: net/minecra

ft/server/mod_NetherOres : Unsupported major.minor version 51.0

17:47:36 [sEVERE] at java.lang.ClassLoader.defineClass1(Native Method)

17:47:36 [sEVERE] at java.lang.ClassLoader.defineClassCond(Unknown Source)

17:47:36 [sEVERE] at java.lang.ClassLoader.defineClass(Unknown Source)

17:47:36 [sEVERE] at java.security.SecureClassLoader.defineClass(Unknown S

ource)

17:47:36 [sEVERE] at java.net.URLClassLoader.defineClass(Unknown Source)

17:47:36 [sEVERE] at java.net.URLClassLoader.access$000(Unknown Source)

17:47:36 [sEVERE] at java.net.URLClassLoader$1.run(Unknown Source)

17:47:36 [sEVERE] at java.security.AccessController.doPrivileged(Native Me

thod)

17:47:36 [sEVERE] at java.net.URLClassLoader.findClass(Unknown Source)

17:47:36 [sEVERE] at java.lang.ClassLoader.loadClass(Unknown Source)

17:47:36 [sEVERE] at sun.misc.Launcher$AppClassLoader.loadClass(Unknown So

urce)

17:47:36 [sEVERE] at java.lang.ClassLoader.loadClass(Unknown Source)

17:47:36 [sEVERE] at java.lang.ClassLoader.loadClass(Unknown Source)

17:47:36 [sEVERE] at java.lang.Class.forName0(Native Method)

17:47:36 [sEVERE] at java.lang.Class.forName(Unknown Source)

17:47:36 [sEVERE] at cpw.mods.fml.common.Loader.loadModClass(Loader.java:4

94)

17:47:36 [sEVERE] ... 7 more

17:47:36 [sEVERE] Unexpected exception

cpw.mods.fml.common.LoaderException: cpw.mods.fml.common.LoaderException: java.l

ang.UnsupportedClassVersionError: net/minecraft/server/mod_NetherOres : Unsuppor

ted major.minor version 51.0

at cpw.mods.fml.common.Loader.load(Loader.java:436)

at cpw.mods.fml.common.Loader.loadMods(Loader.java:606)

at cpw.mods.fml.server.FMLBukkitHandler.onPreLoad(FMLBukkitHandler.java:

134)

at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:125)

at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:428)

at net.minecraft.server.ThreadServerApplication.run(SourceFile:492)

Caused by: cpw.mods.fml.common.LoaderException: java.lang.UnsupportedClassVersio

nError: net/minecraft/server/mod_NetherOres : Unsupported major.minor version 51

.0

at cpw.mods.fml.common.Loader.loadModClass(Loader.java:527)

at cpw.mods.fml.common.Loader.attemptFileLoad(Loader.java:562)

at cpw.mods.fml.common.Loader.load(Loader.java:419)

... 5 more

Caused by: java.lang.UnsupportedClassVersionError: net/minecraft/server/mod_Neth

erOres : Unsupported major.minor version 51.0

at java.lang.ClassLoader.defineClass1(Native Method)

at java.lang.ClassLoader.defineClassCond(Unknown Source)

at java.lang.ClassLoader.defineClass(Unknown Source)

at java.security.SecureClassLoader.defineClass(Unknown Source)

at java.net.URLClassLoader.defineClass(Unknown Source)

at java.net.URLClassLoader.access$000(Unknown Source)

at java.net.URLClassLoader$1.run(Unknown Source)

at java.security.AccessController.doPrivileged(Native Method)

at java.net.URLClassLoader.findClass(Unknown Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

at java.lang.Class.forName0(Native Method)

at java.lang.Class.forName(Unknown Source)

at cpw.mods.fml.common.Loader.loadModClass(Loader.java:494)

... 7 more

>

Erm, not really good with these stuff but i cant start the server as this happen:/ Any help or suggestion? Much appreciated

Share this post


Link to post
Share on other sites

We should stop this turning into a bug reports thread. Andalea, go make a bug report in the proper section please, so this doesn't just become a big bug report in the wrong place. Your problem isn't 3.1.3 specific as far as I know, and even if it was this is probably the wrong place.

Just saying this before it gets too bad.

Share this post


Link to post
Share on other sites

@Windycloud

There should be a zip file in your mods folder called nether ores and another one called advanced machines or something like that.

Delete those and your server will work.

If you want your advanced machines, then replace the api files like Tekkitopotamus said and keep the advanced machines file.

Pretty sure that'll get your server working.

Yeah, also @prolo, I fixed it so it doesn't really matter.

Share this post


Link to post
Share on other sites

There's a better fix to that than just deleting all mods...

If everyone just deleted mods when they didn't work, there would be no need for this thread. My point still stands, this isn't a bug report thread, it's a thread for people to post solutions to problems with 3.1.3, and I'm pretty sure that Windycloud doesn't have a 3.1.3 specific issue.

Share this post


Link to post
Share on other sites

Well...I got tired of waiting for an official fix, so attached to this post are modified versions of the 3 IC2 classes with the minor interface conflict fixes, as follows: ElectricItem.class, EnergyNet.class, NetworkHelper.class

I have uploaded the 3 classes in a tiny zip file here:

ic2 api class fix

There is nothing dangerous about these files - they merely change the path and are just a patch (not the whole ic2 mod).

To fix the IC2 Tekkit 3.1.3 crashing, do the following:

1. Stop your Tekkit 3.1.3 server (if not already stopped...or crashed ^_^ )

2. Go to your Tekkit server mods folder

2. Find the file called: "industrialcraft2-1.103-mcpc1.2.5r2.zip"

3. Open the zip file and go into the ic2/api directory (no need to decompress it - just edit directly)

4. Delete ElectricItem.class, EnergyNet.class, and NetworkHelper.class

5. Download the class fix .zip in the above link

6. Copy the 3 classes from the downloaded zip and paste them into ic2 zip api folder where you just deleted the others

7. Close your ic2 zip and start your server. It should no longer crash relating to this specific interface fix. (It may crash for other reasons, however.)

[NOTE: This change is only for 3.1.3 installs, not 3.1.2]

My server seems to be stable on 3.1.3 with the Nuclear Control update and the attached fixed ic2 classes, including with working Rotary Macerator, etc. I didn't have to delete any advanced machines, downgrade, or reinstall. Also, I haven't really been screwing around with RailCraft, so I can't comment on that issue. I just wanted my automated quarries to work and for the server to be stable.

Finally, my feedback to the Tekkit team on the 3.1.3 release would be that, even though this is an IC2 mod issue, 3.1.3 isn't really a viable "final release". As we have all seen, 3.1.3 doesn't work and there should have been more due diligence and integration testing before pushing it to the public (such as including working Nuclear Control client/server mods which were already released). The upgrade was, no doubt, disappointing for many Tekkit users who wanted to try to upgrade from 3.1.2. Also, it is far beyond the average user ability to be able to install IDEs, decompile and recompile java files, or even set up the required mod build environment with MCP and all the necessary includes (or even understand what was happening to cause the crash in the first place). So, it is in the best interest of all concerned to do a little bit better review, especially given the complicated and diverse mod synchronization and interactions involved in any intended release.

Hope these posts help get most of you up-and-running on 3.1.3. Thanks to Jelato above who saved me some time and no offense to the IC2 modders. (But, it would be nice to have an official MC1.2.5-based fix for 3.1.3. Or, maybe someone wants to rev the 3.1.3 Tekkit client/server installers to 3.1.4 with modifications posted to this thread, perhaps with a RailCraft fix, as required.)

I was having this problem with my server and this patch did in fact fix it but after that i figured okay i can use rotary macerators again so i made an ore refinery but upon starting it up the same error came back i tried reinstalling this patch and even removing advanced machines but none of this seems to fix it is there another patch available? please help

Share this post


Link to post
Share on other sites

Here are a couple links for the modified IC2 zip that I created. I make no guarantees this will work for everyone, but seems to work for me.

Zippyshare

YourFileLink

FileDropper

To be honest though, I would highly recommend switching over to Tekkit Lite because that will most likely be updated more often, and has most of the same mods as Tekkit Classic. It is also a newer minecraft version that will most like run better and with fewer bugs.

Share this post


Link to post
Share on other sites

Also, if it would help anyone, I have already replaced the RailCraft API with those from Buildcraft and re-compressed into a zip. I will upload if anyone wants it.

If I could get that, that'd be awesome. I've tried unzipping the railcraft zip, deleting the BC api, then compressing the zip back (and yes i renamed it back to the original) but then the server won't even run. I get a ModLoader error or something like that. I also notice that my newly compressed zip that has the api deleted is nearly 200 kb larger than the original zip? I feel like there's an error in my Mac compressing the file. Idk.

Share this post


Link to post
Share on other sites

Maybe you help me on my problem? When i go to the server( version 3.1.3) there are three question marks under the server bar where the numbers of players in the server would be. When i click to join the server it comes up with this message, Internal exception: java.net.SocketException: Connection reset. Could you tell me how i can fix this?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this