• 0
daeva

Game crashes in a few ways

Question

Okay so it first crashed while i was playing, then would crash when i opened my world, i looked on this forum & found a guide to reading crash reports & deleted what i was told to delete (some villages.dat file) but now it really wont work. I get this really weird error message when I try to load my world. I saved my world then deleted & reinstalled the pack but still get the same error message. I made a new world which actually worked surprisingly but sadly the world i put a lot of work into wont work. I have a ton of crash reports from troubleshooting but I'll post the most recent one. I tried to get a screenshot of the error message but now it crashes & goes back to the launcher when i try to open my world. Wish I could remember what it said but all I can remember is it was about foodplus & had a bunch of numbers around 6400. Will post a screenshot if possible.

 

crash-2018-04-17_13.58.47-server.txt

EDIT: I changed it back to 1.0.12b from 1.0.13d & managed to recreate the error message. In the crash reports & this error message the foodplus mod is consistently mentioned but deleting the mod also made things worse. 

idmismatch.png

Edited by daeva

Share this post


Link to post
Share on other sites

17 answers to this question

Recommended Posts

  • 0
2 hours ago, daeva said:

Wish I could remember what it said but all I can remember is it was about foodplus & had a bunch of numbers around 6400. Will post a screenshot if possible.

Did you try to update the modpack from 1.0.12c to .1.0.13d?

Share this post


Link to post
Share on other sites
  • 0
7 minutes ago, JaariAtmc said:

Did you try to update the modpack from 1.0.12c to .1.0.13d?

Yes actually! I tried updating it, reinstalling it, I saved my world to my documents then put it back after reinstalling so now i can create new worlds but not use my old one.

Share this post


Link to post
Share on other sites
  • 0
21 hours ago, daeva said:

Yes actually! I tried updating it, reinstalling it, I saved my world to my documents then put it back after reinstalling so now i can create new worlds but not use my old one.

The ID issue is from updating from 1.0.12c to 1.0.13d. Some IDs got changed. You might want to just return to 1.0.12c, updating does absolutely nothing to your world, except making your issues worse.

Your issue is either related to a corrupt chunk, or due to you re-enabling villages. If you haven't re-enabled villages, did you experience a power cut when playing on the world?

Share this post


Link to post
Share on other sites
  • 0
56 minutes ago, JaariAtmc said:

The ID issue is from updating from 1.0.12c to 1.0.13d. Some IDs got changed. You might want to just return to 1.0.12c, updating does absolutely nothing to your world, except making your issues worse.

Your issue is either related to a corrupt chunk, or due to you re-enabling villages. If you haven't re-enabled villages, did you experience a power cut when playing on the world?

I didn't do anything about villages other than deleting that villages.dat file but I'm pretty sure it came back when i reinstalled the modpack. I'm not exactly sure what a power cut is. The first time it crashed was while I was playing & every time after that was while trying to open my world.

Share this post


Link to post
Share on other sites
  • 0
7 minutes ago, JaariAtmc said:

I've moved you 300 blocks from your original location. Hopefully you won't find yourself in a mountain or in lava. Can't promise anything. Don't have your world.

queenkrule.dat

I replaced the file I sent you with the one you sent me, but it still crashes & goes back to the launcher. I have the crash report

crash-2018-04-18_17.18.56-server.txt

Share this post


Link to post
Share on other sites
  • 0
7 minutes ago, JaariAtmc said:

Quick question: Why are you using a server for this?

Second quick question: What is the size of your world?

I'm not sure what you mean by using a server, if I am maybe it's unintentional..? Also it's 69.3 MB

Share this post


Link to post
Share on other sites
  • 0
8 minutes ago, daeva said:

I'm not sure what you mean by using a server, if I am maybe it's unintentional..? Also it's 69.3 MB

Care to zip it up and send it to me using dropbox or something?

Share this post


Link to post
Share on other sites
  • 0
18 minutes ago, JaariAtmc said:

Care to zip it up and send it to me using dropbox or something?

I did zip up the file but now dropbox is asking for money & for me to download it so is there anything else I can send it to you on?

Share this post


Link to post
Share on other sites
  • 0
9 hours ago, daeva said:

I moved to 9_13_17, went to the data folder, and moved the Village.dat and villages.dat out of said folder. And whadda ya know, suddenly the world works again. To make it even better: There's a village on the edge of the visible map.

And whatever you do, do not walk closer to said village.

Interesting: You do have village generation on. It was turned off because of this reason. Something makes villages not work well with biomes o plenty for some (probably stupid) reason.

Edited by JaariAtmc

Share this post


Link to post
Share on other sites
  • 0
15 hours ago, JaariAtmc said:

I moved to 9_13_17, went to the data folder, and moved the Village.dat and villages.dat out of said folder. And whadda ya know, suddenly the world works again. To make it even better: There's a village on the edge of the visible map.

And whatever you do, do not walk closer to said village.

Interesting: You do have village generation on. It was turned off because of this reason. Something makes villages not work well with biomes o plenty for some (probably stupid) reason.

Okay that makes sense thank you for explaining. Not sure where the village is but I'll try to stay away from it aha

Share this post


Link to post
Share on other sites
  • 0
18 hours ago, daeva said:

Okay that makes sense thank you for explaining. Not sure where the village is but I'll try to stay away from it aha

Said village is to the south-south-south-westish of your current location.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.