Jump to content

Non-ops can't break blocks? Help.


Recommended Posts

i know there is a tut on how to get this problem solved but thats if you have forge permissions but what if you have No permissions at all? to answer some stuff my server is a ubuntu server running tekkit lite 0.52 and right out of the box this problem was there. any help to solve this problem would be great.

Link to comment
Share on other sites

If you run it "out of the box" i guess you didn't set any permissions so you gave the answer yourself. You have to set permissions for non-op users or if you don't want to use permissions at all, delete it.

How this can be done:


He is running Tekkit Lite 0.5.2 which does not have Forge Essentials included.

Link to comment
Share on other sites

it's not the spawn thing as one thing i forgot to say is that non-ops can't even open chests and the spawn protection is not the problem it never was.

I just installed a new copy of the Tekkit Lite 0.5.2 server and client, I haven't encountered any of the problems you describe so it seems to be something unique to your install. You could download a new copy of the server and see if that changes anything.

I have no idea why you are having this problem. Do you see a message when you try to place blocks or open chests? If you do, what is the exact message. Does anything appear in the server console or logs?

So why doesn't 0.5.2 have ForgeEssentials included? An oversight, or simply "It's too buggy"?

It is still in beta and I guess Tekkit Lite users were complaining to the authors about it being broken or something when it isn't even finished yet. One of the authors requested that it be taken out until it is further along in its development.

Link to comment
Share on other sites

lets put it this way it's like spawn protect but on the whole server i can try and download a new copy it might help.

Edit: nope new copy did not help but truth be told i did not overwrite the configs as it might have made me get the configs from the server. i also took away the spawn protection but that did nothing. :(

Link to comment
Share on other sites

Well, I am sorry but it seems that I am unable to help you any further. I did some research to see if someone else had your problem but everything else I found was always related to a permissions issue and you said that you did not install any permissions mod or anything.

I have only seen an issue like your when using a permission system, when too close to the spawnpoint, or when the player was lagging. None of these seem to be the cause of your particular problem.

You do not get any error messages or anything in the server console, in-game chat window, or server logs right?

Link to comment
Share on other sites

nope witch is strange. Now i do have vault added would that cause problems being as it's bukkit not tekkit?

Edit: Vault or another bukkit mod was the cause of my problems :( I guess my server website will not be showing the status.

Apparently your definition of "right out of the box" and mine do not match. To me, that phrase means that you made no modifications yourself. I thought that you had just downloaded the Tekkit Lite server zip, extracted it, then started the server.

If I understand your last post correctly, you had tried to add some Bukkit mods to your Tekkit Lite server, right? This would have been nice to know at the start man.

If you want Bukkit plugins for your Tekkit Lite server then you need BukkitForge too. I have not tried to use this myself but according to the sticky in this forum, it works with Vault.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...