Jump to content

Add factorization to tekkit classic


Recommended Posts


I tried adding factorization to tekkit. Downloaded factorization for 1.2.5 from here and added it to my mods folder. Then I tried to run tekkit and got a error about slot 253 being already occupied. Does this mean there are conflicting item id's? And is there a way to change those?

The error log:

42 mods loaded

Optifine OptiFine_1.2.5_HD_S_C6

Minecraft Forge

FML v2.2.106.176

Forge Mod Loader version for Minecraft 1.2.5

mod_CodeChickenCore : Initialized (modpack.jar)

mod_MinecraftForge : Initialized (modpack.jar)

mod_NotEnoughItems : Initialized (modpack.jar)

mod_ReiMinimap : Initialized ([1.2.5]ReiMinimap_v3.2_04.zip)

mod_IC2 : Initialized (industrialcraft-2-client_1.97.jar)

mod_IC2AdvancedMachines : Initialized (AdvancedMachines_4.0_client.zip)

mod_BuildCraftCore : Initialized (buildcraft-client-A-core-2.2.14.zip)

mod_BuildCraftBuilders : Initialized (buildcraft-client-B-builders-2.2.14.zip)

mod_BuildCraftEnergy : Initialized (buildcraft-client-B-energy-2.2.14.zip)

mod_BuildCraftFactory : Initialized (buildcraft-client-B-factory-2.2.14.zip)

mod_BuildCraftTransport : Initialized (buildcraft-client-B-transport-2.2.14.zip)

mod_AdditionalPipes : Initialized (buildcraft-client-DA-additionalpipes-2.1.3.zip)

mod_ComputerCraft : Initialized (ComputerCraft)

mod_RedPowerMachine : Initialized (RedPowerMachine-2.0pr5b2.zip)

mod_ccSensors : Initialized (ccSensors-client-MC125-B017pr1.zip)

mod_CCTurtle : Initialized (ComputerCraft)

mod_EE : Initialized (EE2ClientV1.4.6.5.jar)

mod_EnderStorage : Initialized (EnderStorage-Client 1.1.3.zip)

Factorization : Initialized (Factorization-0.4.0.jar)

mod_IC2NuclearControl : Initialized (IC2NuclearControl_client_v1.1.10b.zip)

mod_ImmibisCore : Initialized (immibis-core_49.1.1_for_1.2.5-client.jar)

mod_InvTweaks : Initialized (InvTweaks-1.41b-1.2.4.zip)

mod_MAtmos_forModLoader : Initialized (MAtmos_packaged.zip)

mod_ModularForceFieldSystem : Pre-initialized (mffs_rev7_for_1.2.5-client.zip)

mod_IC2_ChargingBench : Pre-initialized (mod_chargingbench-client-1.95b-1.2.5-r1.zip)

mod_CompactSolars : Pre-initialized (mod_compactsolars-client-

mod_IronChest : Pre-initialized (mod_ironchests-client-

mod_RedPowerCore : Pre-initialized (RedPowerCore-2.0pr5b2.zip)

mod_NetherOres : Pre-initialized (NetherOres_Client_1.2.1.zip)

mod_PowerConverters : Pre-initialized (PowerConverters_Client_1.3.4.zip)

mod_Railcraft : Pre-initialized (Railcraft_Client_5.3.3.zip)

mod_RedPowerControl : Pre-initialized (RedPowerControl-2.0pr5b2.zip)

mod_RedPowerLighting : Pre-initialized (RedPowerLighting-2.0pr5b2.zip)

mod_RedPowerLogic : Pre-initialized (RedPowerLogic-2.0pr5b2.zip)

mod_RedPowerWiring : Pre-initialized (RedPowerWiring-2.0pr5b2.zip)

mod_RedPowerWorld : Pre-initialized (RedPowerWorld-2.0pr5b2.zip)

mod_TubeStuff : Pre-initialized (tubestuff_49.1.2_for_1.2.5-client.jar)

Balkon's WeaponMod : Pre-initialized (WeaponMod.zip)

mod_WirelessRedstoneCore : Pre-initialized (WR-CBE Core-Client

mod_WirelessRedstoneAddons : Pre-initialized (WR-CBE Addons-Client

mod_WirelessRedstoneRedPower : Pre-initialized (WR-CBE RedPower-Client

mod_ImmiChunkLoaders : Pre-initialized (zdimensional-anchor_rev3.2_for_1.2.5-client.jar)



      Minecraft has crashed!   



Minecraft has stopped running because it encountered a problem.





--- BEGIN ERROR REPORT 28a71710 --------

Generated 25-2-13 14:35


Minecraft: Minecraft 1.2.5

OS: Windows 8 (amd64) version 6.2

Java: 1.7.0_10, Oracle Corporation

VM: Java HotSpot 64-Bit Server VM (mixed mode), Oracle Corporation

LWJGL: 2.4.2

OpenGL: GeForce GTX 460/PCIe/SSE2 version 4.3.0, NVIDIA Corporation


java.lang.IllegalArgumentException: Slot 253 is already occupied by factorization.common.BlockLightAir@5ae8ecbb when adding mffs.BlockMachine@720e179d

at pb.<init>(Block.java:251)

at agy.<init>(BlockContainer.java:7)

at mffs.BlockMachine.<init>(BlockMachine.java:16)

at mffs.mod_ModularForceFieldSystem.load(mod_ModularForceFieldSystem.java:122)

at cpw.mods.fml.common.modloader.ModLoaderModContainer.init(ModLoaderModContainer.java:356)

at cpw.mods.fml.common.Loader.modInit(Loader.java:273)

at cpw.mods.fml.common.Loader.initializeMods(Loader.java:628)

at cpw.mods.fml.client.FMLClientHandler.onLoadComplete(FMLClientHandler.java:223)

at net.minecraft.client.Minecraft.a(Minecraft.java:429)

at net.minecraft.client.Minecraft.run(Minecraft.java:738)

at java.lang.Thread.run(Unknown Source)

--- END ERROR REPORT e64288e1 ----------



Thanks in advance,

Link to comment
Share on other sites

Now that's sorted, you need to change the IDs of Factorisation. You can find them in the config. I reccommend something between 2000 and 3000, make sure every one is different.

If you want to run it on a server, you'll need the Bukkit port, which can be found on mcportcentral if it exists(which it probably does).

Link to comment
Share on other sites

Nope. The Tekkit Classic server uses ForgeBukkit, which requires Bukkit ports of any mods added to the server. If there's no port for Minecraft 1.2.5, you won't be able to add it to Tekkit Classic - or at least not on multiplayer.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...