Jump to content

If Optifine is part of Tekkit, where's the settings for it?


adambomb73
 Share

Recommended Posts

After several new Technic launcher install attempts and even manually trying to include Optifine in the modpack.jar file, I have yet to see the optifine video settings available; the settings are always the same as the default minecraft installation. No fine tuning available. As a result, my FPS ranges all over the place 5-80 but never staying high (>50) for very long). Currently, it's about 20-40 but super super laggy & slow and not sure why after doing a lot of troubleshooting into why the optifine video settings are missing. I've tried new installs after backingup important folders and I've yet to see the optifine video settings after trying out the Technic launcher & the Tekkit Mods package.

Any ideas? Super frustrating....grrr. Thank you for the help.

Link to comment
Share on other sites

Optifine is not part of Tekkit. There are plenty of forum posts already on which versions work; use the search function to find them. And why would you assume that optifine is installed? If there is no evidence of it being installed, checking what mods are in Tekkit probably should have been your first step.

That thread title bugs me from a logic point of view.

Link to comment
Share on other sites

Optifine is not part of Tekkit. There are plenty of forum posts already on which versions work; use the search function to find them. And why would you assume that optifine is installed? If there is no evidence of it being installed, checking what mods are in Tekkit probably should have been your first step.

That thread title bugs me from a logic point of view.

I'm sorry you were bugged by my post, no need to be a jerkoff about it. I have actually done a lot of searches and have found where it's quoted as being included. Maybe they were referring to Tekkit Lite but failed to make the distinction. I've tried the latest versions of both the ultra and standard 1.5.1 optifine using many of the copy/replace modpack.jar files tutorials and neither of the optifine mods worked. If you have some actual constructive input then please look over the last crash report from the last optifine install attempt...

---- Minecraft Crash Report ----

// There are four lights!

Time: 5/24/13 7:16 PM

Description: Failed to start game

org.lwjgl.opengl.OpenGLException: Invalid value (1281)

at org.lwjgl.opengl.Util.checkGLError(Util.java:59)

at org.lwjgl.opengl.DrawableGL.checkGLError(DrawableGL.java:82)

at org.lwjgl.opengl.Display.swapBuffers(Display.java:617)

at net.minecraft.client.Minecraft.func_71357_I(Minecraft.java:517)

at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:406)

at net.minecraft.client.MinecraftAppletImpl.func_71384_a(SourceFile:56)

at net.minecraft.client.Minecraft.run(Minecraft.java:732)

at java.lang.Thread.run(Thread.java:680)

A detailed walkthrough of the error, its code path and all known details is as follows:

---------------------------------------------------------------------------------------

-- System Details --

Details:

Minecraft Version: 1.5.1

Operating System: Mac OS X (x86_64) version 10.6.8

Java Version: 1.6.0_45, Apple Inc.

Java VM Version: Java HotSpot 64-Bit Server VM (mixed mode), Apple Inc.

Memory: 32339688 bytes (30 MB) / 117288960 bytes (111 MB) up to 1606287360 bytes (1531 MB)

JVM Flags: 1 total; -Xmx1536m

AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used

Suspicious classes: FML and Forge are installed

IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0

FML:

LWJGL: 2.9.0

OpenGL: NVIDIA GeForce 8600M GT OpenGL Engine GL version 2.1 NVIDIA-1.6.36, NVIDIA Corporation

Is Modded: Definitely; Client brand changed to 'fml,forge'

Type: Client (map_client.txt)

Texture Pack: Default

Profiler Position: N/A (disabled)

Vec3 Pool Size: ~~ERROR~~ NullPointerException: null
Link to comment
Share on other sites

Sorry.

Download 1.5.1_HD_D1, extract the contents (the unzipped folder), and copy the contents of that folder into a Tekkit-clean modpack.jar. If it asks you to overwrite anything, I believe that's fine, though I've never had to do that before. I've had success with this version, as have other people, but as you're using Mac if this doesn't work it might be an issue with that.

And all mods in Tekkit are listed on the website.

Link to comment
Share on other sites

Sorry.

Download 1.5.1_HD_D1, extract the contents (the unzipped folder), and copy the contents of that folder into a Tekkit-clean modpack.jar. If it asks you to overwrite anything, I believe that's fine, though I've never had to do that before. I've had success with this version, as have other people, but as you're using Mac if this doesn't work it might be an issue with that.

And all mods in Tekkit are listed on the website.

Thank you for the help. Much appreciated. I will try this out when I get a chance. Yes aware of all the mods in Tekkit, but with the confusing Tekkit/Optifine posts floating around on the web didn't know if it was included or not. I also forgot that the Optifine creator doesn't want it to be included in any mod packs, so thanks for the indirect reminder :) Will holler back once I get a chance to try HD_D1.

Link to comment
Share on other sites

Sorry.

Download 1.5.1_HD_D1, extract the contents (the unzipped folder), and copy the contents of that folder into a Tekkit-clean modpack.jar. If it asks you to overwrite anything, I believe that's fine, though I've never had to do that before. I've had success with this version, as have other people, but as you're using Mac if this doesn't work it might be an issue with that.

And all mods in Tekkit are listed on the website.

OK, finally after a busy weekend, able to give this a go...unfortunately same result as error / crash report attached above. The only error listed in the details area is the "Vec3 Pool Size", does anyone know what that is and how to resolve it?

Prior to copy/replace of the optifine 1.5.1 HD_D1 files into the modpack folder, minecraft did load / start ok. It only doesn't start & gives the error after copying the optifine files into the modpack folder and restarting.

Link to comment
Share on other sites

Just installed it and it works fine for me.

Try:

  • Download 1.5.1 HD D1
  • Open the modpack.jar from the Tekkitmain/bin/ folder in the Tekkit files.
  • Drag all of the files from 1.5.1 HD D1 into the modpack.jar.
  • Delete the folder called META-INF
  • Close everything and start Tekkit

Link to comment
Share on other sites

Just installed it and it works fine for me.

Try:

  • Download 1.5.1 HD D1
  • Open the modpack.jar from the Tekkitmain/bin/ folder in the Tekkit files.
  • Drag all of the files from 1.5.1 HD D1 into the modpack.jar.
  • Delete the folder called META-INF
  • Close everything and start Tekkit

Thank you shoe the reply and try. One question, in the bin folder after you did your steps 1-4, did you keep the new modpack file as a folder or did you recompress into a .jar file?

Just for kicks, as I had not tried it before, I kept it a folder named "modpack", but all it did was load a vanilla minecraft version and it did not have the Optifine video options. All other previous attempts after recompressing into a .jar file resulted in the crash report I posted on Friday in this topic (reply #4).

Link to comment
Share on other sites

did you keep the new modpack file as a folder or did you recompress into a .jar file?

You need to keep it as a .jar. How are you opening it? I don't unpack or unzip the file, I just use a program called 7zip to open it as a .jar which lets me see and edit the files inside. I then open the Optifine .zip using 7zip as well, transfer the files and then close 7zip: no unpacking or converting to a file necessary.

I'm pretty sure it won't work as a folder, and I don't know if there are technical problems with just saving a folder as a .jar instead of putting it through some sort of converter. Try just opening the .jar with an archive program instead of unpacking it.

Link to comment
Share on other sites

I don't unpack or unzip the file, I just use a program called 7zip to open it as a .jar which lets me see and edit the files inside.

I don't use a Mac, but OP does and according to the MCF Optifine thread, Mac users apparently have to go through different steps to access the minecraft/modpack jar.

As for the OP, if you've followed the instructions here and in the MCF thread - replacing minecraft.jar with modpack.jar - and it still doesn't work, then I don't know what to tell you. Maybe somebody else will.

Link to comment
Share on other sites

I don't use a Mac, but OP does and according to the MCF Optifine thread, Mac users apparently have to go through different steps to access the minecraft/modpack jar.

As for the OP, if you've followed the instructions here and in the MCF thread - replacing minecraft.jar with modpack.jar - and it still doesn't work, then I don't know what to tell you. Maybe somebody else will.

Yep, I've been following that method along with many other tweeks but nothing seems to work with the Tekkit mod pack. Like you suggested I may just have to try throwing everything in the minecraft.jar like oldschool & see if it works. Something weird must be off with my system.

Thanks Calv & Shoe for the help.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...