Jump to content

Lag on a new tekkit lite server

Recommended Posts


I am having serious lag problems on a brand new tekkit lite server.

You could describe it as 'block lag'. What happens is that client actions are very often delayed for a noticeable, to extreme time.

Mostly the delay is around 0.5 to 1 seconds, but in the worst cases (which happen too often), client actions like placing blocks/opening doors, .. are delayed for like 4 to 8 seconds.

The /ping always shows around 350ms, no matter if there is much lag or no lag.

More information about the installation:

Tekkit Lite on a CentOS 64 bit VPS with 4GB RAM

- ForgeEssentials

- Dynmap

Any ideas what could cause this?

(I forgot that I already had a topic about this, sorry)

Link to comment
Share on other sites

Some things that could cause:

- insufficient/slow computing resources

- slow HDD access

- slow internet connectivity / insufficient bandwidth

- crowded server

- too many chunk loaders / chunks loaded

- high serial computation in game (like removing 1 water source block causing 1000's more to dissapear)

- poor host

You could try upgrading your server or getting a new host. Remember that a VPS is shared between many other people and that a VPS runs at suboptimal levels - If other servers on the same physical machine are eating resources, your server will suffer as well.

A ping of 350 ms without much load is very bad for real time video games.

Link to comment
Share on other sites

The VPS has good specifications so I don't think HDD, CPU or RAM is a problem. The map is just new, so (almost) no machines and no chunk loaders.

There are also no serial placed blocks. I will check if the internet connection is good.

Link to comment
Share on other sites

The internet connection is just fine.

Any ideas? :/ I really need to get this problem fixed because you can't do anything on the server.

Is there any way I can check for myself why the server is so laggy? Any tools for checking what happens during a tick or something like that?


internet connection test with SSH:

--2013-07-03 20:54:18-- http://cachefly.cachefly.net/100mb.test

Resolving cachefly.cachefly.net...

Connecting to cachefly.cachefly.net||:80... connected.

HTTP request sent, awaiting response... 200 OK

Length: 104857600 (100M) [application/octet-stream]

Saving to: `100mb.test'

100%[======================================>] 104,857,600 11.1M/s in 9.1s

2013-07-03 20:54:27 (11.0 MB/s) - `100mb.test' saved [104857600/104857600]

FINISHED --2013-07-03 20:54:27--

Downloaded: 1 files, 100M in 9.1s (11.0 MB/s)

Link to comment
Share on other sites


yes, it was during primetime.

Something tells me that it is simply a bug in the internet connection.

ram, cpu, .. all works fine. The client has no fps lag so then it must be the internet connection right?

maybe the port isn't forwarded correctly? or is that not possible on a vps?

Link to comment
Share on other sites

I asked them several things but they seem to stop replying..

I must be getting annoying with all my questions

However I really think the problem is the host because when typing some things in SSH while the server is lagging, those characters also take ages to appear.

I'm getting so pissed from all of this :/ This is not the first time I tried making a tekkit server. I tried 2 hosts before this one, and every time there are weird problems.

I've been trying to create Just simply a tekkit server, for over than a month now. Still no luck. All I have done is wasting money. Luckily you are helping me out now :)

Link to comment
Share on other sites

Hard Disk Space: 150gb

Bandwidth: 6000gb

Guaranteed Ram: 4094mb

Burstable Ram: 4096mb

CPU Units: 1000

CPU Speed: 4000mhz

CPU Cores: 2

Until now, the server only has 2 players on it because we don't want to open it with these lag problems. (the lag also happens when you are alone on the server)

We should be having around 15 players when it is opened.

Link to comment
Share on other sites

I'm going to have to agree that the problem is with the host. I don't have too much experience with finding Minecraft hosts, so I can't help you out there. Perhaps you can find a good one by word of mouth and seeing what other people use.

Link to comment
Share on other sites

It could just be that the server is located in some far away land. Narnia for example. Distance could be the cause of latency. Try typing /gc if you have essentials. That'll show you server info such as TPS, Available Memory, and used memory.

Link to comment
Share on other sites

hmm that command isn't working. It is ForgeEssentials.

The server is indeed in a far location but the lag I'm having is way longer than the ping. (20second delays instead of 350ms ping)

@Meems33: Hmm again another host :/ I think I'll keep trying to fix this because changing host again is really the last thing I want :/

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...