Jump to content

Unable to craft items from 'More Bows' Mod after latest update


Recommended Posts

I'm posting this here because I'm mostly certain this is somehow my own fault, and not a bug in Hexxit itself:

I run my own server. Last week, I had been using version 1.0.1 because I'd had the file there for a while and forgotten to check for updates. In that world, everything seemed to work as it should, till I noticed that I was unable to craft the Hookshot (Items got sent back to inventory). In retrospect, I'm certain that everything in the same mod was also non-existant in the game. When I went online to see what the problem was, I realized that my verison was outdated, and assumed that was the issue.

So I've updated to 1.0.5, client and server alike, and in my fresh world I'm able to both craft and spawn the Hookshot. I thought that the issue had been solved, up until this morning when a friend pointed out to me that we could not craft the Crystal bow, or any items from the 'More Bows' mod.

I re-downloaded the latest server files and uploaded them twice, even updating the version of FML in the minecraft_server.jar to see if that would fix the issue, but it persists. I've tried copying config files from my client to the server and vice versa, but nothing changes. Looking around online people are saying it's a conflict in the config files, but that doesn't seem to be the case this time. Could anyone help me find the cause of this issue?

Link to comment
Share on other sites

Odd, I haven't noticed this so far. I'll investigate it immediately. Please write a bug report so that 'hopefully' one of the staff will actually look at it.

... hopefully.


My Hexxit server came with a pre-generated set of config files.

Could you go into your hexxit server's config files and look for the more bows.cfg, see if the IDs overlap those of your client, if not, adjust and see if that works.

Make sure B:z is set to True


Link to comment
Share on other sites

I made the bug report directly after posting my comment. Monitoring both now. I'm also going to attempt to roll back to 1.0.4 on the server to see if anything changes. By chance, would you happen to know of any persistent bugs in that version?

Link to comment
Share on other sites

The first attempt I made was pretty silly. I just pasted version 1.0.4's files onto the server and overwrote anything that was a different size from the source files. I ended up being able to connect to it with both 1.0.4 and 1.0.5 clients, with some crazy worldgen, but I still wasn't able to spawn in the Legia bow.

Now I entirely removed the coremod, mod and config folders and I'm replacing them with the older version. I'll update on how that goes in a few.

Update: Success! Both Hookshot and the More Bows mod are working. Looks like it's back to 1.0.4 for me. Let's hope the mod creators figure out the cause of the problem soon.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...