Jump to content

Server hangs (not?) related to Mystcraft


Timendainum
 Share

Recommended Posts

A problem has developed on our server over the past few days related to MystCraft.

We have a small server with just a handful of players, and we noticed over the last few days that the server has been hanging. A reboot seemed to clear things up, but over night the server would hand again and require another reboot.

Today I've been tracking the issue down and it is related to MystCraft. About 30 seconds to a minute after entering any MystCraft age the server will hang and drop all players with some type of connection timeout exception.

There is nothing in the server.log and nothing in the forge logs related to what is happening.

If no one enters a Mystcraft age the server will remain running.

I've tried creating a new age. Same behavior.

I've tried deleting all the existing ages and creating new ones, and the server still hangs.

i'm downloading a local copy off the server for some local diagnoses, but I really need some help on where to start here.

Link to comment
Share on other sites

A little more investigation. I've downloaded the server locally and been playing around with it. Server will actually "freeze up" if you leave it alone for long enough.

Although entering a mystcraft age will still kill the server in about 30 seconds, to a minute.

The process isn't freezing, but the server drops all clients, and will not take any new connection. It will not respond to console commands. It isn't using any CPU, and only about 1GB of RAM.

Link to comment
Share on other sites

It's an issue with the very weak multi-dimensional controls in vanilla minecraft. Minecraft it's self has a hard time dealing with more then about 3 or 4 dimension being active at a time, the more memory the server has available, the more dimensions it can handle, to a point... Add in mystcraft dimensions, the end, and the nether, and the server can end up running out of memory if they are all active. Either by players being in them, or by chunk loaders. Dimensional doors mod can cause this problem as well, but the tiny size of each dimension(pocket dimension, or puzzle dimensions) minimizes the effect on the server. Limbo on the other hands has as much of an effect as any other dimension.

Are any of the mystcraft ages chunk loaded? If so, is it more then just 2 or 3? Are players using custom ages for their forts? Are there any ages, stored on the server, that can be deleted to free up storage space, like unused ages or ones that never quite turned out right?

You can start by having your players go through and remove chunk loaders from any dimension that they do not need to have active all the time.(this includes the end and the nether if they are not being used for resources) Once this is done, have then all travel back to the over world and save/quit. Reboot the server and see if this has any effect on how it runs with everyone staying in the overworld for a while. If this does NOT help, then the simple solution isn't enough, sadly...

If this does help. Then the simple solution is to limit the number of total ages allowed to be chunk loaded on the server to a small number of community ages and limit them to just 1 personal age at most, preferable not chunk loaded. If all goes well, you can try letting them each have two ages at most and go up from there as long as the server can still handle it. Just keep the chunk loading limited to as few ages as possible. Overworld does not count for the sake of chunk loading dimensions.

Some though will have to be made to find other possible solutions if the simple solution does not work.

Link to comment
Share on other sites

Jakalth,

Thank you very much for the reply. I wish what you were describing above was the issue.

I've tried completely deleting all the ages.

There aren't any chunk loaders in the areas directly, but something that did happen early on was we set up another set of quarries in our mining age, and it seemed like they might have been causing the crash early on. But, I'm not confident, I think we were just misreading the corelation to being in the age for 30 to 60 seconds.

The server will also stop responding if no one is logged in. If you stay in the overworld and do not go into myst ages it will keep running, but log off for a few mins and the server will hang. Go into any age, and it will just die right away.

Now, I did try something, I took the MystCraft mod out of the mods folder and tried booting up the server. And of course I can't test going into an age. But, I did test the letting the serve become idle, and sure enough, after a few minutes the server hangs.

So, this kinda dismantles the Mystcraft as the cause.

Any ideas on how I can debug this?

Link to comment
Share on other sites

Hmmm. pondering the ponder able. Something might have gotten corrupted in the server files. possibly one of the mods, hopefully not the world its self... could try reinstalling the modpack onto the server. Just be sure to backup your world so you can restore it if this fixes the problem.

If that's not it... maybe an issue with dimensional doors mod? it used to have issues with mystcraft. But when you removed myscraft that should of fixed those issues as well... Hmmm...

not really sure what mods could cause issues like this... Unless... Galacticraft? not very likely though...

Link to comment
Share on other sites

Alright, I figured it out.

It wasn't Mystcraft at all. I ended up figuring out that it was really hanging when no one was in the overworld area. If I went to the nether I had the same issue.

So some more playing around lead me to finding a recent change that left a small, but really important part of the Applied Energistics system outside of a chunk loaded area.

So, putting down a new chunk loader completely eliminated the problem.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...