Sign in to follow this  
BatDood

Map Markers Disappearing

Recommended Posts

I'm running a personal server for my family and a couple of close friends. I've got this problem that's really making me scratch my head and I could really use some help.

 

Everybody's map markers vanish. It's a totally random event that usually happens when I shut the server down and restart. I run this server off my computer and I don't leave it running 24/7. I only fire it up when people want to play on it.

 

The funny thing is, it doesn't happen all the time. It's really unpredictable and because of that, quite frustrating. We also have instances where explored areas of the map disappear as if we've never been there before.

 

I'm waiting for the moment when someone is in the Nether and see that their Portal marker has vanished when they've logged back on. I know we could write down coordinates but doesn't that kind of defeat the purpose of having this mod?

 

I would REALLY appreciate some insight as to why it keeps resetting.

Share this post


Link to post
Share on other sites

Sounds like an issue with Map Writer and the server info no longer matching up between restarts. Why? Not sure. But as islands420 said, post this on the tracker. Include the server logs for a few days (if available) and some of the various players launcher logs as well. It should help track down any issue like this. Also, if able, post the contents (ie: folder names) of the "mapwriter_mp_worlds" folder (./modpacks/attack-of-the-bteam/saves/) for a few players as well when the report is made. Link to the tracker (and its guidelines) available in signature below.

Share this post


Link to post
Share on other sites

I just thought I'd follow up on this topic further. I've got a solution to this problem. It's not pretty but it does the trick.

 

My IP is dynamic (as I'm sure most average folk's are), and whenever my internet or router is reset for whatever reason, I get assigned a new IP address. Every time the IP changes, Mapwriter looks at it as though you're playing on a fresh world save resulting in everything disappearing.

 

The work around is to log onto your world after your IP resets and back out. This creates a new folder for the new IP address. Then go into your Saves folder followed by the mapwriter_mp_worlds folder. Copy everything from the old IP folder into your new IP folder that got generated and overwrite everything when prompted. All markers and explored areas are back in your map again.

 

I don't know if this would really be considered a "bug" as it could be a structural property of the mod itself. I just thought I'd let others know the about the solution that might be having a similar issue.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this