Jump to content

Annoying Lag Spikes


budderman21
 Share

Recommended Posts

Hi all,

 

I have been playing Attack of the B-Team for awhile now and truly enjoy it. The only drawback is that I get periodic lag spikes that don't make it unplayable, but are just really annoying.

 

If anyone could help, that would be great.

 

So far, I have installed OptiFine, changed ingame video settings to lower settings, and allocated 3GBs of RAM via the launcher. I also set javaw.exe to use the NVidia processor in the NVidia Control Panel, but the problem is still there.

 

I have tried allocating 4GB of RAM through the launcher, but to no avail.

 

I am playing on a laptop, but I don't think it is heat because I am using a cooling pad when I play, and I have never had previous issues with overheating. It only happens while I am on battery power, too.

 

My specs:

 

Intel core i7 3630QM @ 2.4GHz (Turbo up to 3.4GHz)

NVidia GeForce GT 635M 2GB

8GB DDR3 RAM (2x4gb sticks)

Windows 8.1 Home Premium

 

It only happens in SSP. When I go onto a LAN server run on my mom's laptop, I never dip below 100 frames.

 

I should also mention that I am using Sphax 128x. Backing down the resource packs resolution definitely helps to remove the spikes, though I like the clarity of the 128x over any other, and would like to continue using it.

Link to comment
Share on other sites

It'll be the turbo mode and CPU throttling when you're on battery power (it waits until it definitely needs more processing cycles before stepping up by default), this probably won't be noticeable in the client (though it'll still be happening), but it'll be obvious if it happens on a server (which is what you're doing when you run SSP).

 

What you'll need to do to stop it is to change the setting that the laptop is on when using battery power - win8 has a "power options" section in control panel, unplug the laptop, look in there, and you should see it's on Power Saver (or it's got some override by the laptop manufacturer) selected.  Change it to Balanced (the usual default) or High Performance (never throttles performance down much, even if it's not being used).  If it is on some other setting made by the manufacturer then they'll have some application that manages it, so find and use that instead.

 

 

Usually this kind of thing goes on the Tracker here, but it's not really a problem with the pack or Technic Launcher or any mods running or anything, so I guess the discussion forum is as good a place as any :)  (This is just an FYI for future reference, technical problems tend to go there as technical people tend to go there).

 

Let me know how that goes!

Link to comment
Share on other sites

What you'll need to do to stop it is to change the setting that the laptop is on when using battery power - win8 has a "power options" section in control panel, unplug the laptop, look in there, and you should see it's on Power Saver (or it's got some override by the laptop manufacturer) selected.  Change it to Balanced (the usual default) or High Performance (never throttles performance down much, even if it's not being used).  If it is on some other setting made by the manufacturer then they'll have some application that manages it, so find and use that instead.

 

Just for other laptop users experiencing this threads issue: These settings are also available in the control panel on windows vista, and windows 7 laptops under the same name. Windows XP should have it in the same location as well, but unsure on this one.

Link to comment
Share on other sites

I did some testing and the CPU is in fact throttling, down to about 1.8GHz from 3.2 when the spikes occur. My power plan is set to max performance and was from the start. I did some research and I might need to lower my minimum processor state in the power settings. I am going to try that later and will let you know how that works.

EDIT: The CPU actually clocked down as low as 1.1 GHz. Any ideas as to what could be causing the throttling (besides heat?)

Edited by budderman21
Link to comment
Share on other sites

The computer has different power settings depending on if it's on battery or not, make sure you check the power plan when it's unplugged and see that it's the same.

 

In those settings there's a 'minimum processor state' which is sometimes a percentage and sometimes a clock multiplier, either way if it's on Max Performance that shouldn't be turned down from max anyway.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...