Jump to content

issue with openblock tanks


zibafu
 Share

Recommended Posts

Hey, so on my server with my friend, my smeltery was really fully of metals, so I decided to have a system where the liquid is pumped out of a drain via liquiducts and filtered into various tanks with whitelisting and pneumatic servos, in front of each tank is a casting basin or table, with a separate liquiduct and lever controlling liquids going into it, underneath the tables are itemducts and a chest at the end for the blocks/ingots to go to. (picture will be included)

 

So ive set this up, and at first it seemed to work, however now, only the first tank which holds iron seems to accept it, the rest of the tanks just get ignored and all the metals end up back in the smeltery Ive been over the system a couple of times now, the whitelisting is all done correctly, so I am baffled as to why this is happening.

 

Any ideas anyone ?

 

Ive just tried a server restart in case it was a glitch, but nothing

 

I do plan on building a structure around this, but seems pointless to do so until its all working correctly ?

 

 

2h5no1l.png

Link to comment
Share on other sites

Is there still iron in the smeltery?
 If so thats your problem. The iron is pumped to fast through the circuit and is in the smeltery before the next liquid can be pumped through it, resulting in an endless iron stream.

I am using generikb's setup for my automatic smeltery which works like a charm:

 

Edited by BrowserXL
Link to comment
Share on other sites

hmm, I think I get what you mean, the other liquids do get pumped through the circuit as well, like I just logged on now and tried it, and I have a tank for molten glass, the iron went through the circuit, thne the glass did, and the glass tank started filling some more, it only seems to be certain tanks that dont wanna accept - emerald, seared stone and molten aluminium, then some aluminium brass and then bronze went through and also went into their tanks, there was some spillover going back to the smeltery.  But the emerald, seared stone and aluminium just ignore their tanks.

 

Seems like a really odd issue, I've seen generikb's smeltery but I'll check it out again

Link to comment
Share on other sites

I had this issue as well, and it seemed as if the liquids can flow thru the liquiducts faster than the tanks will accept and or the servos can process. After letting a setup run for a while (afk so no idea how long it was) it did work itself out.

 

One thing I noticed that did help was that extra tank he has in line at the end. As he said when he built it, it was a very important little piece. 

 

I had initially thought to see if I could make pipes dense and or vacuum like the item ducts but have since just stuck to not using the liquids as much and just using the smeltery as needed instead of having a bunch on hand. I have found that I dont really use it much now that I have a more advanced system and plenty of resources to work with. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...