Jump to content

How to?!

Recommended Posts

As far as i am aware EE is not ported over to bukkit in the way you are wanting to be.

What i mean by this is EE just works or does not work - you cannot stop people from using it.

However, you might be able to use some 3rd party bukkit plugins to disallow/allow players of certain ranks to craft/place/use/carry EE items, however im unsure of what plugin could do this, but im sure there would be one there somewhere.

Link to comment
Share on other sites

The answer you're looking for is PermissionsEx which can be found here. You will need to open the modifyworld config and allow item restrictions and then you can use nodes like this:

- -modifyworld.blocks.place.237

Stops users from placing the block stated


- -modifyworld.items.have.237

If a user has this item in their inventory, it will be removed

There are other nodes that can be used and are listed here, but I'm not 100% sure if they're all compatible with Tekkit items.

Link to comment
Share on other sites

I tried doing that Nentify but it still won't work, this is the pex I have for the group and here is the config from the modify world

enable: true

itemRestrictions: true

informPlayers: false

whitelist: false


  whitelistMessage: You are not allowed to join this server. Goodbye!

  prohibitedItem: You have prohibited item "%s".

  permissionDenied: Sorry, you don't have enough permissions




    default: false


    - serversigns.use.*

    - essentials.sethome

    - essentials.sethome.multiple

    - essentials.tpa

    - essentials.tpaccept

    - essentials.tpdeny

    - essentials.home

    - essentials.spawn

    - essentials.nick

    - essentials.afk

    - essentials.helpop

    - ultimatearena.player

    - sortal.warp

    - factions.kit.halfplayer

    - iConomy.access

    - iConomy.payment

    - iConomy.list

    - sb.use.money

    - sb.use.xp

    - sb.use.atm

    - modifyworld.*

    - modifyworld.blocks.interact.*

    - modifyworld.blocks.destroy.*

    - modifyworld.blocks.place.*

    - -modifyworld.blocks.place.x126

    - -modifyworld.blocks.destroy.x126

    - -modifyworld.blocks.interact.x126

    - -modifyworld.blocks.place.x130

    - -modifyworld.blocks.destroy.x130

    - -modifyworld.blocks.interact.x130

    prefix: '&f[&2Member&f] '

Link to comment
Share on other sites

Have you de-opped yourself, given yourself member, removed the x's and tried destroying block ID 130?

Also, just noticed. You need to remove the negated permissions ABOVE the modifyworld.*, it reads from the top, so it reads modifyworld.* first and allows members to do anything within Modifyworld. If you put the negated permissions above, it should work.

Link to comment
Share on other sites

Hey there for help paste this into the bottom of your config file in modify world

use-material-names: false

drop-restricted-item: false

item-use-check: false

Then is will work if you have done the permission nodes right on tekkit and made sure you

have used ID: number ID not names. If you used names then set use material names to true

Simples :)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...