Jump to content

Disable optifine


Recommended Posts

Go to the config file and enter "enable=false" and "enablemp=false". Good luck remembering all the recipes.

How are Optifine and NEI (Recipe helper) related in any way? Are you sure that you haven't been hit on the head as a child?

Link to comment
Share on other sites

Yeah, I think there is confusion there. Bear in mind though that without optifine, there is no way you will ever be able to use anything higher than 16x16 graphics. The MCPatcher does not play well with Forge mods, which are prevalent in the Technic/Tekkit packs. So make sure that you want to remove optifine.

I would highly suggest looking over other optifine versions and installing one of those over the one you've got instead of removing it.

Link to comment
Share on other sites

In normal minecraft I have about 100 fps. But while using Technic/Tekkit I have about 30 (on lower settings than usually). I disabled ALL mods (in config file) and Tekkit runs at 50 FPS which is just gay. I am nearly 100% sure it's optifine's fault (because what else could it be?!)

Link to comment
Share on other sites

In normal minecraft I have about 100 fps. But while using Technic/Tekkit I have about 30 (on lower settings than usually). I disabled ALL mods (in config file) and Tekkit runs at 50 FPS which is just gay. I am nearly 100% sure it's optifine's fault (because what else could it be?!)

Bear in mind those mods need other code to run them, so the reason your rates might be dropping is just more code is using memory. Optifine being one, modloader, bukkit being two others respectively. Plus any API for whatever mod and who knows what else. Although Optifine usually improves performance as SilverSomething mentioned.

Link to comment
Share on other sites

Yeah I figured that ninjakivi2, I must have been out of it when I replied the first time.

How much memory do you have allocated? I've read some things about memory, and found that increasing your memory allocation "too far" your FPS can actually drop again, and give you serious lag. and likewise, the vanilla allocation is probably not enough for the mods.

As the smart people above me have already said: Optifine is there to improve framerate, but if you want to still try and remove it you could try this: In theory, depending if your up to it, you could manually remove all of optifines '.class' files from the bin.jar. But the trick is, that Optifine (I'm pretty sure) modifies vanilla .class files. So you could do a side-by-side comparison (or find out which files it changes), then re-insert the vanilla files to re-overwrite the Optifine ones.

Hope that made sense, I could be out of it again... ;) At any rate, if you give this a shot I have one thing to say... BACKUP YOUR .JAR FIRST! that is all.

Link to comment
Share on other sites

Torezu: No, I'm not using a laptop. The weakest part of my computer is dual core processor.

In Technic options I allocated 1GB, because any higher/lower value crash minecraft too often. In Java properties I didn't changed anything, and by default minecraft have 1GB of ram. (I have 3GB)

Well, I'll have to get all the mods and install them one by one to see if low fps is caused by optifine.

Link to comment
Share on other sites

Stop.

You have 3GB? Ok, how much of that is usable RAM? If you're running Windows 7, most of that is going to be used up just in the OS alone. I've got 6GB installed, half of that is useable. I still have to run Minecraft with only 512 allocated because I, like you, have only a dual core processor. Although other games run well, Minecraft suffers as a result.

Link to comment
Share on other sites

Try editing the Technic launcher properties file to use 768 instead. Then make sure your view distance is no higher than Normal, and turn some graphics settings down. That's usually what's necessary to play Technic relatively smoothly with 32-bit Java.

Link to comment
Share on other sites

Stop.

You have 3GB? Ok, how much of that is usable RAM? If you're running Windows 7, most of that is going to be used up just in the OS alone. I've got 6GB installed, half of that is useable. I still have to run Minecraft with only 512 allocated because I, like you, have only a dual core processor. Although other games run well, Minecraft suffers as a result.

I use f*c*i*g windows vista, but it only use about 700 MB of ram (don't ask me how I did this) ;) I tryed to experiment wits different options, but when I change something minecraft just randomly crash :(

And of Course I can just lower my settings to increase fps, but that's not the point. I want to disable optifine and that's it.

Link to comment
Share on other sites

Oh nobody answered OP's question yet?

Download Optifine from their site, open up the zip. Open modpack.jar and remove all files that are the same. Then go grab latest forge from their site (3.3.8+) and add those files to modpack.jar

You have to add forge back again since some of the files are shared.

Link to comment
Share on other sites

Oh nobody answered OP's question yet?

Download Optifine from their site, open up the zip. Open modpack.jar and remove all files that are the same. Then go grab latest forge from their site (3.3.8+) and add those files to modpack.jar

You have to add forge back again since some of the files are shared.

Thanks a lot that will be helpful.

By the way: yes, I wanted to disable optifine, but deleting it is still more than satisfying.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...