Jump to content

How Does One Create a Tekkit 3.1 Server?


Recommended Posts

Hi. I'm new to these forums, so forgive me if I missed a thread that has this question answered.

But, here's my situation.

I had set up a Tekkit server for Tekkit 1.2.5 and that worked fine on my Mac connecting my friends and I through Hamachi. Now that the new version has come out, I don't know how to upgrade because I followed a tutorial off of YouTube that provided a specific folder with all the tools I needed. He hasn't updated his video, so I'm kind of in the dark regarding his methods.

So I know 'Bukkit' is a thing, but I don't know how to exactly use it.

So the simple question I'm trying to ask is:

"How do I run a Tekkit 3.1 server on a mac? (With or without Hamachi)"

Thanks guys!

Also, I updated my Tekkit launcher, but it still says its running Minecraft 1.2.5....

Any thoughts on this?

Link to comment
Share on other sites

Have you tried just extracting the Tekkit 3.1.2 archive over the top of your existing Tekkit installation?

As regards version number, the version number of the Tekkit mod pack (3.1.2) is different to the version number of the underlying Minecraft game installation (1.2.5.)

Link to comment
Share on other sites

I think littleweseth is dead on here, I think you're getting the Minecraft and Tekkit version numbers mixed up. Minecraft just upgraded to 1.3 from 1.2.5, but Tekkit doesn't have a version for Minecraft 1.3 yet.

If you're old server is running Minecraft 1.2.5 then you'll most likely be on Tekkit 3.1.1 or 3.1.2 so you're probably already on the latest version of Tekkit.

And before you ask "When is Tekkit going to come out for 1.3?" the answer is at least a few weeks, maybe longer.

Link to comment
Share on other sites

I see. Thanks for clearing this up for me littleweseth and Object. I didn't realize Tekket 1.3 wasn't out yet. I haven't checked up on Tekkit's website for a while, and with the new change in layout, I thought for some reason that it updated to 1.3 (even though it said 3.1 ...)

However, when I download the new server files, it says the date modified is newer than the files I have. So when I try and overwrite the files, the server can't run, it gets an error. Is it an outdated start.command file? Or is it something else?

Much appreciated guys!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...