Jump to content

Large RedPower Frame Quarry won't work

Recommended Posts

Hello Technic Forums.

I made a small 5x5 FrameQuarry yesterday , and it worked perfectly. Today a friend and i expanded it, massively increasing drillhead's size, but it doesn't work any more. The wiring is pretty much the same, only thing that's changed is that the size has been increased. I'll add some screenshots. Please help me! :c





Link to comment
Share on other sites

Redpower is configured to only allow 1000 entities to be moved at once using frames. I don't know the specific underlying mechanics (i.e. does this mean 1000 blocks of space, or do frames+covers/panels count as more than 1 entity? Do players/mobs count towards this limit?) but this number can be changed in the redpower.cfg file.

More likely, though, is that when you expanded the quarry, you have something that wasn't correctly picked up by the frame, and is blocking movement. Eloraam said she wanted to add "sparks" or a "grinding noise" when frames are blocked from moving, but that hasn't been implemented yet, so until that happens, it'll be a lot harder to debug frames.

FYI, Frame Construction 101: Always, ALWAYS perform redundancy testing. Every time you add something, test everything that came before.

Link to comment
Share on other sites

first, check the linksize.

then, get rid of all of the normal blocks that don't need to be their. the first rule of building with frames is that whenever possible you ONLY build with frames. it makes it easier to bug check and less likely to develop bugs

have you tried removing the outer layers and adding them back on one at a time?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...