Jump to content
  • 0

Server Not Launching - cpw.mods.fml.common.LoaderException



I ran a small server for me and my friends on an old laptop so I can keep it running all the time. My laptop started acting funny so I flashed it with DBAN and reinstalled windows. And now I get this Log.txt every time I attempt to launch it. Anybody know how to fix?

I've tried downloading another server for Tekkit classic, but I get the same Log.txt


D:\Server>java -Xms512M -Xmx1024M -jar Tekkit.jar nogui pause
182 recipes
27 achievements
18:22:55 [INFO] Starting minecraft server version 1.2.5
18:22:55 [INFO] Attempting early MinecraftForge initialization
18:22:55 [INFO] Completed early MinecraftForge initialization
18:22:55 [INFO] Forge Mod Loader version for Minecraft 1.2.5 loading
18:22:55 [SEVERE] Unable to process our input to locate the minecraft code
18:22:55 [SEVERE] cpw.mods.fml.common.LoaderException
18:22:55 [SEVERE]       at cpw.mods.fml.common.ModClassLoader.getParentSources(ModClassLoader.java:77)
18:22:55 [SEVERE]       at cpw.mods.fml.common.Loader.load(Loader.java:374)
18:22:55 [SEVERE]       at cpw.mods.fml.common.Loader.loadMods(Loader.java:606)
18:22:55 [SEVERE]       at cpw.mods.fml.server.FMLBukkitHandler.onPreLoad(FMLBukkitHandler.java:134)
18:22:55 [SEVERE]       at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:135)
18:22:55 [SEVERE]       at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:438)
18:22:55 [SEVERE]       at net.minecraft.server.ThreadServerApplication.run(SourceFile:492)
18:22:55 [SEVERE] Unexpected exception
        at cpw.mods.fml.common.ModClassLoader.getParentSources(ModClassLoader.java:77)
        at cpw.mods.fml.common.Loader.load(Loader.java:374)
        at cpw.mods.fml.common.Loader.loadMods(Loader.java:606)
        at cpw.mods.fml.server.FMLBukkitHandler.onPreLoad(FMLBukkitHandler.java:134)
        at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:135)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:438)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:492)

Edited by Emberss
Add log
Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0
43 minutes ago, cpdough18 said:

How did you fix it?

I just looked back in discord history, it looks like they used Java 10, while tekkit classic is (I think) Java 7 max. Potentially Java 8 max. Do not use Java 9 or higher than that.

Also please make your own posts in the future instead of necroing almost 2y old threads. This thread can walk around already...

Edited by JaariAtmc
Link to comment
Share on other sites

This topic is now closed to further replies.
  • Create New...