• 0
Stonemaster55

Technic Launcher isn't opening at all

Question

so there I was casually playing minecraft on the launcher. I go and exit for a quick second and try to go back on the launcher and it wouldn't open. I clicked the TechnicLauncher.exe file and nothing. i tried resetting my computer and even deleted everything and reinstalled it, but nothing. Its not even bringing up a loading screen or any error warnings. Please help, I really wanna play minecraft. 😅

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

have you read this?

make sure you do. We need more information, like; your OS and java you have?

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)
6 hours ago, Munaus said:

have you read this?

make sure you do. We need more information, like; your OS and java you have?

I'm running on windows 10 and have java x64

I followed the link and put the log into pastebin.com, but I don't know what this means:

[B#448] 2019/08/23 09:54:47 [INFO] Console Mode Activated
[B#448] 2019/08/23 09:54:47 [SEVERE] java.lang.NoClassDefFoundError: com/sun/awt/AWTUtilities
[B#448] 2019/08/23 09:54:47 [SEVERE]     at net.technicpack.ui.controls.installation.SplashScreen.<init>(SplashScreen.java:84)
[B#448] 2019/08/23 09:54:47 [SEVERE]     at net.technicpack.launcher.autoupdate.TechnicRelauncher.buildUpdaterTasks(TechnicRelauncher.java:108)
[B#448] 2019/08/23 09:54:47 [SEVERE]     at net.technicpack.autoupdate.Relauncher.runAutoUpdater(Relauncher.java:97)
[B#448] 2019/08/23 09:54:47 [SEVERE]     at net.technicpack.launcher.LauncherMain.main(LauncherMain.java:198)
[B#448] 2019/08/23 09:54:47 [SEVERE] Caused by: java.lang.ClassNotFoundException: com.sun.awt.AWTUtilities
[B#448] 2019/08/23 09:54:47 [SEVERE]     at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:583)
[B#448] 2019/08/23 09:54:47 [SEVERE]     at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(ClassLoaders.java:178)
[B#448] 2019/08/23 09:54:47 [SEVERE]     at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:521)
[B#448] 2019/08/23 09:54:47 [SEVERE]     ... 4 more
[B#448] 2019/08/23 09:54:47 [SEVERE] Unhandled Exception in Thread[main,5,main]
java.lang.NoClassDefFoundError: com/sun/awt/AWTUtilities
    at net.technicpack.ui.controls.installation.SplashScreen.<init>(SplashScreen.java:84)
    at net.technicpack.launcher.autoupdate.TechnicRelauncher.buildUpdaterTasks(TechnicRelauncher.java:108)
    at net.technicpack.autoupdate.Relauncher.runAutoUpdater(Relauncher.java:97)
    at net.technicpack.launcher.LauncherMain.main(LauncherMain.java:198)
Caused by: java.lang.ClassNotFoundException: com.sun.awt.AWTUtilities
    at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:583)
    at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(ClassLoaders.java:178)
    at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:521)
    ... 4 more

Edited by Stonemaster55

Share this post


Link to post
Share on other sites
  • 0
16 hours ago, Stonemaster55 said:

I'm running on windows 10 and have java x64

I followed the link and put the log into pastebin.com, but I don't know what this means:

[B#448] 2019/08/23 09:54:47 [INFO] Console Mode Activated
[B#448] 2019/08/23 09:54:47 [SEVERE] java.lang.NoClassDefFoundError: com/sun/awt/AWTUtilities
[B#448] 2019/08/23 09:54:47 [SEVERE]     at net.technicpack.ui.controls.installation.SplashScreen.<init>(SplashScreen.java:84)
[B#448] 2019/08/23 09:54:47 [SEVERE]     at net.technicpack.launcher.autoupdate.TechnicRelauncher.buildUpdaterTasks(TechnicRelauncher.java:108)
[B#448] 2019/08/23 09:54:47 [SEVERE]     at net.technicpack.autoupdate.Relauncher.runAutoUpdater(Relauncher.java:97)
[B#448] 2019/08/23 09:54:47 [SEVERE]     at net.technicpack.launcher.LauncherMain.main(LauncherMain.java:198)
[B#448] 2019/08/23 09:54:47 [SEVERE] Caused by: java.lang.ClassNotFoundException: com.sun.awt.AWTUtilities
[B#448] 2019/08/23 09:54:47 [SEVERE]     at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:583)
[B#448] 2019/08/23 09:54:47 [SEVERE]     at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(ClassLoaders.java:178)
[B#448] 2019/08/23 09:54:47 [SEVERE]     at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:521)
[B#448] 2019/08/23 09:54:47 [SEVERE]     ... 4 more
[B#448] 2019/08/23 09:54:47 [SEVERE] Unhandled Exception in Thread[main,5,main]
java.lang.NoClassDefFoundError: com/sun/awt/AWTUtilities
    at net.technicpack.ui.controls.installation.SplashScreen.<init>(SplashScreen.java:84)
    at net.technicpack.launcher.autoupdate.TechnicRelauncher.buildUpdaterTasks(TechnicRelauncher.java:108)
    at net.technicpack.autoupdate.Relauncher.runAutoUpdater(Relauncher.java:97)
    at net.technicpack.launcher.LauncherMain.main(LauncherMain.java:198)
Caused by: java.lang.ClassNotFoundException: com.sun.awt.AWTUtilities
    at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:583)
    at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(ClassLoaders.java:178)
    at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:521)
    ... 4 more

You have java 64 bit yes. But java 12, not the java 8 you should have.

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)
6 hours ago, JaariAtmc said:

You have java 64 bit yes. But java 12, not the java 8 you should have.

I do have java 8, but I checked and for whatever reason java 12 was on here too. I deleted that and it works now. Thank you! 😅

Edited by Stonemaster55

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.