• 0
Sign in to follow this  
Lady Serena Kitty

Client unable to use server

Question

Title: Client unable to use server

Version: 0.5.1

OS: Client: Windows 8; Server: FreeBSD 8

Java Version: Client: Oracle Java 7u6; Server: OpenJDK 7u6

Description of Problem:

Tekkit Lite client cannot connect to the server

Error Messages:

2013-01-05 18:29:10 [iNFO] [ForgeModLoader] User ladyserenakitty connection failed: missing [], bad versions [MFReloaded|CompatIC2, MFReloaded|CompatRP2, MFReloaded|CompatPamsHarvestCraft, MFReloaded|CompatExtraBiomes, MFReloaded]

2013-01-05 18:29:10 [iNFO] [Minecraft] Disconnecting ladyserenakitty [/10.25.1.100:65518]: The server requires mods that are absent or out of date on your client

Error Log:



Share this post


Link to post
Share on other sites

12 answers to this question

Recommended Posts

  • 0

Do you have WinRar installed on your computer? If so, WinRar (from what I've observed on my own accounts) prevents files from being read because instead of a .zip file with the mods (as it should be) there is a .rar file with the mods which is unreadable. If you have WinRar you need to convert the files to standard .zip OR uninstall WinRar.

Share this post


Link to post
Share on other sites
  • 0

That will also do it. 7zip and WinRar are *essentially* the same thing at their core and what they are used for. The only downside to having them if you're trying to run a server that requires the .zip files for mods (or even plugins) is that they become compressed into a file the server cannot read. My only suggestion would then be to remove the compression files from the client machine and see if it works. If it does and you try and use a mod (let's use NEI for example) and you click an item and it boots you, it means the server also needs to have the compression tools removed from it as well. Why it's effecting your client more than your server I do not know, but that is the only thing I can suggest that would be of any assistance at all.

Share this post


Link to post
Share on other sites
  • 0

Compression tools on the BSD machine are only active when run from the shell. Since there's no GUI on any of my servers, only a limited number of services actually run on them. If anything were messing up the JAR reading on my server, it would be the package "archivers/unzip" which is a runtime dependency of the JVM. Java on FreeBSD requires the zip and unzip commands since ZIP functionality is not embedded within the JVM on FreeBSD.

Share this post


Link to post
Share on other sites
  • 0

@Lady Serena, I'd have to say to run the server and client both on the same machine then. I do, it only causes a bit more lag for your client while you're on the server then because you're running both. It's sad to say you can't use a server on a different machine because of compression tools, but that's why I don't use them anymore.

@CaleKing, Mac is having many known issues with TekkitLite. I have no idea how to correct these as I'm a Windows connoisseur. There are some Mac pages with bugs like this, (and even the Technic Team states are are a lot of bugs with Mac clients, I would recommend using the .jar file as they stated to) so take a look at those.

Share this post


Link to post
Share on other sites
  • 0

@CaleKing, it even states these Mac issues that I just addressed on the top of the page telling you exactly what to do to use everything. Follow those instructions and you'll be fine.

Share this post


Link to post
Share on other sites
  • 0

I'm running Voltz on a Mac and I have the same problem. I dont understand why. I am running both on the same version. I also tried manually installing the most recent mods but that didnt work. When I run the most recent version of voltz (1.1.0) it says that it needs the earlier versions of the mods and when i run voltz on the recommended version (1.0.11) it says that the server requires mods that are absent or out of date. All the mods are there and when I would try to update the mods, it says I need the older versions. I really want to get this server working for my friends.

Share this post


Link to post
Share on other sites
  • 0

I'm running Voltz on a Mac and I have the same problem. I dont understand why. I am running both on the same version. I also tried manually installing the most recent mods but that didnt work. When I run the most recent version of voltz (1.1.0) it says that it needs the earlier versions of the mods and when i run voltz on the recommended version (1.0.11) it says that the server requires mods that are absent or out of date. All the mods are there and when I would try to update the mods, it says I need the older versions. I really want to get this server working for my friends.

You just answered your own question. You're using server 1.1.0 and client 1.0.1... you need to use the SAME version. If your server is 1.1.0, on your client select the same build from the options.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this