Jump to content

Logistic provider pipes fail to provide RE battery


Recommended Posts

I just ran into this yesterday. It's a documented issue with IC2's handling of meta-data/damage-values and pops up with various rechargable items such as RE-Batteries. Essentially the form of the item being requested by an automatic crafting table doesn't match what it's being given. Here's one link where you can read about it: https://github.com/RS485/LogisticsPipes/issues/187

Of all the potential solutions I came across on various pages yesterday none seemed to work reliably but I noticed one guy saying he simply used an automatic crafting table mk.2 for that particular recipe and it worked. This has also worked for me so I'd suggest trying it. I believe I read that this IC2 issue is either very difficult to fix or unlikely to be fixed, though I'm not sure which page I saw that on.

Then again, your post is a little challenging to understand so I could be responding to something entirely different than what you intended. Try punctuation sometime.

Link to comment
Share on other sites

Just a thought after reading that thread that zero pointed out, wouldn't having a crafting logistics pipe connected to an mfsu or something else IC2 set to take the no damage batteries and 'damage' them so that the logistics system would recognise them as the batteries needed for the craft work? It seems like an easy fix but I have no way of testing this right now. If someone could try this would you mind posing your results?

As for the problem of not able to request them, have you imported the materials correctly? You have to right click the crafting logistics pipe with a BC wrench and click "import" if its connected to an auto crafting table and has the recipe in place. Also, make sure you have all the materials needed connected to the pipe network with (correct me if I'm wrong)a supplier logistics pipe. And unless it got updated, they do not need to be powered.

Link to comment
Share on other sites

I think I found a temporary solution for recipes using those RE batteries. I simply put double set of those REs on the automatic crafting table and set up the correct recipe (without these extra REs) for crafting pipe manually. For example - I used six batteries instead of three to set up Bat Box recipe on the table (not on the pipe!) That way the REs don't turn "uncharged" and stack up just fine and these extra set of REs always stays on the table (somehow - no clue why they are not getting used each time).

Set up LV Solar Array line that way. And a Bat Box crafting as well. So, I guess, it works.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...