Jump to content

Windows 8 blah blah fullscreen lagg blah blah


Recommended Posts

I originally posted this on overclock.net, but they haven't answered in a day so I'm trying my luck here to see if anyone can help me with this!


So, I just recently upgraded my Win7 to Win8 (both 64-bit) *applause*

I can't express well enough how pleased I am that they did NOT **** it up... *looks at Vista*

Now, I am a big fan of fullscreen-gaming on one monitor while watching series, movies or just use my second monitor in general while playing on the other one.

This worked without fail in Windows 7 as I've done this for the past two years or so.

However, this seems to not be viable anymore with my Win8 after I updated both my OS and my drivers from NVidia. When I fullscreen a game on monitor 1, my WHOLE second monitor laggs badly (except for the mouse). Everything from the start-menu, my web browser, quite literally everything laggs except my cursor.

As you may understand, this is an annoyance for me and I would like to assault the problem and kill it with fire.

My specs are as follows;

i7 2600k OC'd to 4.2 GHz


8 GB RAM running at 1333 MHz

Windows 8 pro 64-bit

Again, I did not have this problem on Win7 with the exact same specs. It worked before. Now it doesn't.

Good luck in figuring this out, cuz I sure as hell can't! :D

Link to comment
Share on other sites

there's a setting in nvidia's control panel called "multi display/mixed-GPU acceleration", try setting it to "multiple display performance mode". I have no idea if that will actually do anything, but it sounds like it might matter for your situation.

Link to comment
Share on other sites

Thanks for the answer, but it's sadly already set to that in Global Settings.

I finally got an answer over at Overclock too, and they say it's a problem with Windows 8 probably which makes me a sad panda/pony. I think it's most likely a lost cause, but if anybody (or you, Freakachu) have any other suggestions I will gladly try them out. :)

Link to comment
Share on other sites

In my experience, Windows 8 is not actually the horrible crappy OS everyone makes it out to be. The metro UI just has a really steep learning curve. I have learned both, and I still prefer 7 by miles, but as far as the UI goes, 8 is really not that horrible. Just different. As for compatibility and tweak-ability… yes, it does have issues.

Link to comment
Share on other sites

So, this isn't really a "fix", but it's some kind of workaround.

First, http://forums.steampowered.com/forums/showthread.php?t=2675769

This guy has made something great. Download that small file, run it and follow his instructions. CONGRATZ.

With this program I was able to run Skyrim, Hitman, Metro, Dead Space 2, Euro Truck Sim 2 (DON'T JUDGE ME), RAGE - pretty much everything in Bordered Window-mode without any problem.

And people who said it's a problem with WIndows 8, you are completely correct. Windows 8 basically caps the framerate of windows and programs running in the background - and running a fullscreen game will automatically do just that... Put everything else as background.

However, this is a fix until Microsoft eventually (hopefully) fixes this small screw-up. Happy gaming weekend, guys!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...