Jump to content

Freezes while moving


Eadword
 Share

Recommended Posts

First let me clarify that it is more of a glitch, it does not fully freeze but it kind of stops for a split second to half a second before continuing and that happens about every 3 seconds - 2 seconds while moving around. If running or flying it is more pronounced than walking, but it is noticeable and annoying. I noticed this first on my server when I decided to test it out for performance and noticed this problem, the entire time I was watching the CPUs on my server and it stayed below 40% the entire time once I as connected. I then tried to duplicate the problem on single player and found the same problem, the only thing I found I could do to decrease the problem is reduce the render distance and other methods of reducing quality such as setting it to power saver rather than max fps.

Nothing that I tried actually fixed the freezing, just reduced it. I do not think it is my computer since I did not have this problem back a few versions, although I am unsure of when it started. Is this just me and is there a fix?

Link to comment
Share on other sites

This is a memory issue.

I had this same problem and had to increase permgen and memory allocated from 1gb to 1.5gb just to not have this constantly. It still occurs from time to time and when it does the used ram climbs to 1.3-1.4gb.

Try running around with the debug overlay (F3) and hide the mini map if it covers your memory text ( default "M", change the config to another key [ I use N ], two mods conflict and it displays the world view instead of hiding the map )

It shouldn't be running near the limit all the time. Flying will increase it as its constantly loading/generating new chunks on top of the normal processing.

My setup:

Linux 64-Bit

Ram 4 GB

Swap 8 GB

Link to comment
Share on other sites

I gave Big Dig 8GB so I am pretty sure that it is not the issue, that and the fact that it never uses close to that much, usually less than 50%. I also have always had the increase perm gen option selected since I first got the Technic launcher. Sorry for not doing a better job listing my settings the first time. If it makes any difference I am running Linux Mint 15 64-bit with 16GB ram 0 swap, 60GB partition on SSD (39.8GB free), and a 3.6Ghz Quad from AMD, I also have a nvidia gt440 and run 2 displays at 1920x1080 (if it makes a difference) and I have set my graphics driver to be the recommended one, not the default non-proprietary one.

I grant that some of that is probably not useful, I am just trying to cover everything. Oh and when I ran the server it was on a separate local computer.

I also just ran it again now and although it does still glitch a little it is less pronounced even with the same settings, there are no differences in my background load. It could have been the Linux Mint updates I had just installed but it seems smooth now, well as smooth as minecraft ever is.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...