Jump to content

Mobs are not spawning


Buttneck
 Share

Recommended Posts

Mobs just don't seem to be spawning on my server. I have monster spawning set to "true" in the default config files. Is there another setting I need to look at somewhere?

I noticed when I press "L" on the keyboard, it brings up a list of "mob buttons" but these don't seem to have any effect. What is that screen for? It has three settings down below: Disabled, Square, and Guides, and a "Done" button.

Link to comment
Share on other sites

- You may have too many mobs spawned already. This used to happen with Endermen with the Dimensional Doors mod- you'd have some raw rifts spawn on worldgen, spread, get out of control, and then Endermen would start spawning from them like mad. I haven't heard of this happening in more recent versions of Dimensional Doors, but I suppose it's possible.

- The L key is the Monster Spawn Highlighter options menu- Monster Spawn Highlighter displays the nearby blocks which monsters can spawn on top of- that screen allows you turn on/off the highlighter, and pick which mobs the highlighter is active for.

Link to comment
Share on other sites

Thanks for the reply. I'll search a little harder. There are some pretty big caves under my area, but if too many mobs had spawned already, you'd think I would hear them occasionally. (zombies moaning etc.)

Is there an easy way to clear all the mobs out? Will resetting the server do this?

Link to comment
Share on other sites

I did have an issue on 1.2.2 that I think I caused. I used the safari net to collect a lot of animals and put them in an open penned farm just outside the house. Bread them for a bit and then notice it that whole area no mobs would ever spawn. I think it was because so many friendly mobs (sheep, cows etc) were already in the area so it refused to spawn anything else.

Link to comment
Share on other sites

I did have an issue on 1.2.2 that I think I caused. I used the safari net to collect a lot of animals and put them in an open penned farm just outside the house. Bread them for a bit and then notice it that whole area no mobs would ever spawn. I think it was because so many friendly mobs (sheep, cows etc) were already in the area so it refused to spawn anything else.

Friendly mobs are actually in a separate spawn pool from hostile mobs.

Link to comment
Share on other sites

I am running version 1.3.9 and I am having the same problem, I think it may have something to do with a Dimensional Anchor that has been on for a while. For the longest time there was no problem with the hostile mobs spawning and now I find that there are none at all around my Anchor, I did try going outside of its effect always and found some hostile mobs like I would expect but not as many, I have my server set to hard. Is there a way to tell the server to regen all of the mobs? I have not noticed any endermen problems with the dimensional doors either.

On second thought could it have something to do with the added dungeons? It seems that they all have many spanners and since there are about 6 levels on some of the underground ones that seem to be everywhere...

Link to comment
Share on other sites

Come to think of it, there are those vast dungeon stronghold things in Big Dig with room after rectangular room and a lot of spawners. That could be it. I have since started a new world and the problem has corrected itself.

CanVox, how do you disable "certain types" of dungeons?

Link to comment
Share on other sites

- You may have too many mobs spawned already. This used to happen with Endermen with the Dimensional Doors mod- you'd have some raw rifts spawn on worldgen, spread, get out of control, and then Endermen would start spawning from them like mad. I haven't heard of this happening in more recent versions of Dimensional Doors, but I suppose it's possible.

- The L key is the Monster Spawn Highlighter options menu- Monster Spawn Highlighter displays the nearby blocks which monsters can spawn on top of- that screen allows you turn on/off the highlighter, and pick which mobs the highlighter is active for.

ive seen this on our server (its pretty cool to see), and we have zero hostile mobs spawning anywhere except these endermen. but they are far away from where anyone spends any time, wouldnt thes ehave to be in the chunks you have loaded to screw up the mobs spawning in your area?

ive done a ton of searching and it seems lots of people have this problem, it might be a 1.4.5 vanilla bug actually.

one guy put torches in a 272 x 272 block area, to create a mob farm in a dark building in the middle of the area, and found mob spawn rates dropped over time. the theory is that mobs would spawn at the very edge of the area and get stuck, so they would count as a spawned mob, but not be in an area that tey could even show up to the player. Or something like that.

The guy put torches out to 300 x 300 blocks, and mobs started spawning again. but it seems there are many ways in which hostile mobs can stop spawning. in our old world it happened overnight, in our current world it dwindled over time until we just cant get any mobs to spawn at all except from spawners. Sucks.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...