Jump to content

Why no uranium by default? (In SSP or SMP)


Recommended Posts

Please note: This post is NOT about the lack of uranium in world creation. It's about the logic to the default being set to false.

My attitude may seem strange here but I'm very new to even vanilla MC as well as any mods. I may not understand how this community disseminates information and thus I'm missing the obvious so I'm sorry to repost if this has been asked but I was unable to find anyone addressing my question. I was, however, able to find the "solution" to my problem of there being no uranium in my worlds. I believe there are two changes to make in the config for atomicscience. One allows ore to exist and the other makes it radioactive. I'll switch those to true and get to digging in a new chunk.

What I have not been able to wrap my head around is why at least non-radioactive uranium ore is not set to true by default. I work from the assumption that the makers of the mod allow for tweaking values that can change the balance of game play and that maybe repackagers like technicpack may tweak again due to rebalance the game play in light of the other mods they know they have included. Sounds cool to me.

I always like to play a mod "as shipped" thinking it is how the mod designers first wanted me to experience the new world. For example, when I play console games, I try to start on what the designers made for "normal" or "hard" play. I can adjust up or down after first seeing the game as they first delivered. I'd hate to find I have to go into a preference setting on a new game and turn on "weapons do damage", for example.

If I had found some sort of official "getting started" text on the web site for the atomic science mod that said "when you ready to play with our mod, you will first have to switch on uranium ore creation and radiation by...."

Someone on a forum suggested that it was an oversight in SSP because so many developers test and debug with a focus on multiplayer. I fetched the server version but even there the ore and radiation are turned off as delivered. I feel like I really tried hard to find some statement from the actual author(s) to explain why it's off by default. Instead I can only find guidance from fans of the mod telling me what change I needed to make and this seems strange to me. That's why I ask about this default setting before I casually switch it on.

What can anyone tell me about this? Can anyone give me any pointers to other mods included as standard in tekkitmain that need intervention before useful?

Link to comment
Share on other sites

Uh, I was under the impression that the generation was turned off because retro-genning was enabled to support 1.0.6 worlds.

Thanks for your nudge in the right direction. Your answer does seem to be speaking to what I'm asking but as an outsider that's just getting started I'm not taking your full meaning. I believe I understand that retro-genning is adding new ores brought in by a mod to an existing world (chunk even), correct? Are you saying they don't need these options turned on anymore because there is another method used now to bring uranium into the worlds? I have set some large 64x64 quarries (pre-atomicscience.cfg change) and never found a uranium block. That's what got me noticing there was something I had to look into here. Also, can you tell me what you mean by 1.0.6 worlds? I'm not sure whose version that is. I assume not vanilla MC engine, nor does it seem to be in line with AS's versions.

Maybe more to the point, can you tell me what is my best process to get started in playing with the AS mod included with tekkitmain? Should I be switching on options in atomicscience.cfg in a fresh world and start mining? As I said, I'm very new to this. From what I can gather, if you want to play with fission reactors, you need uranium and if you expect to split a few atoms you'll need to process uranium ores up through a few stages with some other machines. If this mod needs its ores switched off by default, are there other mods included in tekkitmain that are in the same "because retro-genning was enabled to support..." circumstance that I should know about before I dig into them?

From some of the tutorials I have seen on youtube on playing with AS, I am very excited to build up to this power output level through legit play and I hope with the help you and others provide I can get things dialed in correctly.

Link to comment
Share on other sites

I don't actually play Tekkit so may not be of much help, but regarding your query about other mods that may have their ore gen switched off, you want to check in the COFH World config file. At the bottom of this will be listed all the custom ores that COFH is generating (Uranium is probably in there). You can check then to see if these other ores are actually spawning.

ps. As I said I don't play Tekkit, I'm only going off the way CanVox configured BigDig (which I have played extensively), and I'm presuming he did the same here.

Link to comment
Share on other sites

Sorry, my bad.

1.0.6 was the reccomended version of Tekkit previous to the latest which you are probably playing, 1.1.10.

CoFH core never occured to me, Belone, that's probably it. I'd check that, but keep in mind Uranium is extremely rare. You may just have not found any.

Link to comment
Share on other sites

No, AnotherFineMess is correct. Uranium Ore generation is off by default in Tekkit 1.1.10.

Furthermore, I agree with him. It is both annoying and doesn't make sense. I expect it was an oversight.

On my server we created a new Mystcraft age just to mine Uranium, and after the first set of quarries came back empty we were scratching our heads. We found the solution buried in an older post on this forum.

Edit: Actually... see this post, this may be a bug:


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...