Jump to content

Tinker's Construct Smeltery Controller Broken


Zorblork
 Share

Recommended Posts

Hey Everyone,

 

I have a problem with the Tinker's Construct Smeltery. I have lots of space in it and it is barely halfway filled, but when I look at the Controller GUI, it appears as if it was overflowing. Some of the metal types are being pushed so far up that i can no longer access them. I tried to break and rebuild the smeltery entirely, but after a while it happened again. I have no idea what causes this, any ideas?

 

Pic.:

 

http://imgur.com/IGvAFQ6

 

This is what it looks like. Gold, Alumite, or anything else are not even visible at this point.

Link to comment
Share on other sites

Update:

 

I just started draining it completely. While doing so, the GUI sometimes goes absolutely blank, as if it was empty (even though it isn't). As soon as the type of material is actually empty, the rest will reappear.

 

@StratusNightstar: Tried that, didn't seem to change anything, it only changes the "active" material as usual.

Link to comment
Share on other sites

I did. It let me see more of it, but it still looks horrible and i cant access all the materials.

 

I drained it and rebuild the entire thing. After that it seemed to be fine for a while, but now it is back to this (this time with small GUI):

 

http://imgur.com/5DQzCPX

 

I really can't think of anything else to do. In this state the Smeltery is pretty much unusable.

Link to comment
Share on other sites

I could've sword I had my smeltery do this once (I was just chucking anything and everything in so there were a lot of different ore and alloy combinations in there), but I can't replicate it now to isolate what's causing it to report it properly.

 

Can you show screenshots of the way it's built so I can see if it's got anything in common with any of my pre-modification versions of the smeltery?

 

It's definitely a bug that needs to be added on the tracker though if you haven't done already.

Link to comment
Share on other sites

Just to clarify with my suggestion.  When you have the Smeltery interface up and you hover over the bottom resource in the smeltery and you shift+right-click it will send that resource to the top and everything moves down one.  So, when having that interface issue where you can't see everything, if you do this you can effectively scroll through all your available resources. 

Link to comment
Share on other sites

I dont think the smeltery was ever intended to store stuff, I always cringe when I see youtubers doing this.

 

As AcesOyster suggested, when you finished using the smelter always empty it with either the casting basin or a ingot cast.

 

If you do insist on keeping liquid metals on hand, then store them in a tank

Link to comment
Share on other sites

  • 5 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...