Jump to content

Server Crashes.


Recommended Posts

I think this is where I should post this. If not i'm sorry!

Well basically my server was running fine then I started getting severe errors and crashes on my server resulting with my members not being able to get on and me having to manually restart the server. Which is clearly not do-able all the time. I tried the usual remove all the plugins then add them singularly which stopped them being so frequent but they still tend to happen. Anyway here's the error.

2012-05-14 19:39:33 [sEVERE] java.lang.NullPointerException

2012-05-14 19:39:33 [sEVERE] 	at net.minecraft.server.NetworkListenThread.a(NetworkListenThread.java:63)

2012-05-14 19:39:33 [sEVERE] 	at net.minecraft.server.MinecraftServer.w(MinecraftServer.java:543)

2012-05-14 19:39:33 [sEVERE] 	at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:441)

2012-05-14 19:39:33 [sEVERE] 	at net.minecraft.server.ThreadServerApplication.run(SourceFile:465)

2012-05-14 19:39:33 [sEVERE] Unexpected exception

java.lang.NullPointerException

	at net.minecraft.server.NetworkListenThread.a(NetworkListenThread.java:63)

	at net.minecraft.server.MinecraftServer.w(MinecraftServer.java:543)

	at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:441)

	at net.minecraft.server.ThreadServerApplication.run(SourceFile:465)

2012-05-14 19:42:54 [iNFO] Read timed out

2012-05-15 03:55:02 [iNFO] [35m[server] Server restart/shutdown commencing.[0m

2012-05-15 03:55:02 [iNFO] CONSOLE: Forcing save..[0m

2012-05-15 03:55:03 [iNFO] CONSOLE: Save complete.[0m

2012-05-15 03:55:03 [iNFO] [35m[server] Running save-all[0m

2012-05-15 03:55:03 [iNFO] CONSOLE: Forcing save..[0m

2012-05-15 03:55:03 [iNFO] CONSOLE: Save complete.[0m

2012-05-15 03:55:03 [iNFO] [35m[server] Stopping server.[0m

2012-05-15 03:55:03 [iNFO] CONSOLE: Stopping the server..[0m

2012-05-15 03:55:03 [iNFO] Stopping server

I'm not sure what other information you guys will need. I'm running on the latest Tekkit build released. Here's the plugins that I have installed at the moment;

Minequery

WorldEdit

Towny

iconomy

Register

Lockette

PermissionsEX

WorldGuard

Essentials

EssentialsChat

ChatManager

TownyChat

EssentialsProtect

EssentialsSpawn

That should be them all.

All the tekkit mods are enabled.

Here's the full server boot log;

http://pastebin.com/upcYSxai

Hope someone can help it's annoying everyone on the server including staff.

Thanks in advance to anyone who attempts to help!

-SyMOD EDIT: Don't do that.

Link to comment
Share on other sites

This is one of the pesky one. Have this happend before? And will the server restart? If it runs, please start it again, and post another crashlog when it happends. The idea is to get some more player/logindata, to determine who is causing this, the location of it etc.

If it crashes during startup, try to dissable chunkloaders and see if it wont start up then. If it does, wait till it crashes again, and provide a new errorlog.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...