Jump to content

Trouble with PEX+Tekkit


Recommended Posts

'lo,

many of Tekkit mods use 'fakeusers' like [buildCraft], [RedPower] and [industrialCraft] to account for their block_place events. In Tekkit 2 I put the fakeusers in user groups and gave them permissions with pex, but looks like that doesn't work anymore. If I give [RedPower] all the perms it needs for block_place (and /pex toggle debug reveals it indeed doesn't run into any "permission not found" situations) it still can't place down a block with deployer. If I do /op [RedPower] then deployers work again so it's definitely a permissions issue. Opping quarries and industrial tnt and such isn't exactly ideal so I'd rather use pex if possible.

Anyone run into this problem?

Link to comment
Share on other sites

No need to bump, and why not combine these threads since their literally the same http://forums.technicpack.net/index.php/topic,12075.0.html

As I asked in that other thread, what does your modifyworld config look like?

Also why don't you want to OP the fake users? OP'ing the fake users most of the time removes constant permissions checks and give the mods the freedom they need to work (which is a good thing). I would recommend OP'ing the mods over relying on * and having pex constantly checking permissions for those mods.

Link to comment
Share on other sites

I would rather handle the fakeuser permissions with pex because then I can limit their permissions so that players cant for example use a quarry to destroy a worldguard protected area or use blockbreakers to smash lwc-protected chests.

modifyworld config:

enable: true

itemRestrictions: true

informPlayers: true

whitelist: false

messages:

whitelistMessage: You are not allowed to join this server. Goodbye!

prohibitedItem: You have prohibited item "%s".

permissionDenied: Sorry, you don't have enough permissions

Also it's worth noting that modifyworld (or any other plugin) doesn't restrict any non-fake players that have the same perms as the fake players. It's just the fake players that get restricted somehow, maybe they communicate with pex via different api or something?

Link to comment
Share on other sites

op'ing [ComputerCraft] doesn't help for me.

Here is my modifyworld/config.yml:

enable: true

itemRestrictions: true

informPlayers: true

whitelist: false

messages:

whitelistMessage: Du darfst diesen Server nicht betreten. Goodbye!

prohibitedItem: Du hast das verbotene Item "%s".

permissionDenied: Entschuldigung, aber du hast nicht das Recht dazu.

Link to comment
Share on other sites

op'ing [ComputerCraft] doesn't help for me.

If you want the mining turtles to work then you would have to OP each ComputerCraftTurtle1067, ComputerCraftTurtle1068 etc. or have your default group so that it has modifyworld perms in the area (though as described above simple modifyworld perms are not sufficient anymore in tekkit 3).

Link to comment
Share on other sites

Hmm, that doesn't solves it for me, since for example the quarry work only outside the faction areas.

That is the whole idea. If you want quarries to be able to break protected areas then /op them. If you want your protections to mean anything then block machines from destroying them.

Link to comment
Share on other sites

I thin you missunderstand: I alread OP'ed them and they are still not able to operate in Faction Areas. Also the factions.bypass permission is given to them but I think the problem whith that is, that usually as admin you also need to perform a command to enable/disable the bypass functionality. Since the mod fakeplayers dont actively write commands to the chat to activate bypassing factions, the have the right to do so but they cant enable that function.

A possible solution would be, if it was possible to perform a chat command for a player. Is that possible? So lets say I would like player xyz to use /home or something, like sudo. That way I could enable the bypassing by myself by saying

/sudo [buildcraft] /f bypass

What im asking myself too is, why don't I see at least the attemp of the mod fake players asking for some permissions when I switch debugging in pex on?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...