• 0
Sign in to follow this  
Kghareus

Tekkit/Technic not using GPU

Question

I recently got a new computer and it has an Intel GPU built in and an Nvidia GPU. Regular Minecraft uses the Nvidia one without issue but I can't seem to figure out how to get Tekkit or Technic to use it. I tried telling the computer to use the GPU when running the technic launcher but that didn't work.

Share this post


Link to post
Share on other sites

11 answers to this question

Recommended Posts

  • 1

I have a laptop with the same issue (given to me for work use, but hey, if you can't play Minecraft on it...)

Right-click anywhere on the desktop and select NVIDIA Control Panel. Go to Manage 3D Settings on the left. Under the Global Settings tab, change the Preferred graphics processor to the NVIDIA card, and under the Program Settings tab, click Add next to the drop box for programs, go find java.exe and javaw.exe, and you might as well add Minecraft and the Technic Launcher as well. Apply and close. Voila!

Share this post


Link to post
Share on other sites
  • 0

You need to tell it to always use the GPU when dealing with either Java in general, or do so for modpack.jar and minecraft.jar in the .techniclauncher folder. The launcher is only active for a moment, after that it just launches a special version of minecraft.

Share this post


Link to post
Share on other sites
  • 0

Well, then you need to find your Java runtime exe, and tell it to use the GPU, because the launcher assembles the jar, and then launches the Jar using java.

Share this post


Link to post
Share on other sites
  • 0

Jar's are just package files that stores the code the java runtime environment interprets, so the actual exe program that runs minecraft is the javaw.exe found in \program files\java\<version>\bin\

Share this post


Link to post
Share on other sites
  • 0
Hidden

I started up technic, went into task manager and looked. It says technic was using Java.exe. I right clicked on it then clicked "Open file location" It brought me to the jre7 folder to the Java.exe file. I went into the GPU settings and told it to use the high performance GPU on Java.exe. It's still not using it for tekkit/technic.

Share this post


Link to post
  • 0

Then you may have to do some kind of shenanigans to uninstall (or make the system think you uninstalled) the Intel Integrated Waste of Space.

Share this post


Link to post
Share on other sites
  • 0

I was having the same issue with my NVIDIA GPU and a google search lead me here so I thought I might share my solution.

My problem was that I added the java and javaw applications that were in /Program Files (x86)/java/bin, but after checking in the task manager, I found out it was using the applications located in /Program Files/java/bin. After adding those my GPU is being used whenever I launch Tekkit or Voltz.

I hope this can be of help to anyone having the same issue with Tekkit and/or Voltz. And remember, if you have the program open, you can always use the task manager to find the location of the .exe by right clicking the task you are curious about.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this