manikminer123

Platform crash when loading pack 1.7.10 Modded

4 posts in this topic

Hai so I have a modpack which is buggy, It has an issue with NEI where if  I try to get a recipe the game crashes. This is because the NEI has issues with my RotaryCraft, ElectryCraft and DragonAPI (Reika Mods) versions. I update the three mods and my modpack no longer loads.

NEI Crash report for recipe's:   https://pastebin.com/NTfuPzvz

Crash log for the launcher with updated RC,EC and DAPI:   https://pastebin.com/8CTM3Nkz

Share this post


Link to post
Share on other sites
On 31-10-2017 at 6:07 PM, manikminer123 said:

Hai so I have a modpack which is buggy, It has an issue with NEI where if  I try to get a recipe the game crashes. This is because the NEI has issues with my RotaryCraft, ElectryCraft and DragonAPI (Reika Mods) versions. I update the three mods and my modpack no longer loads.

NEI Crash report for recipe's:   https://pastebin.com/NTfuPzvz

Crash log for the launcher with updated RC,EC and DAPI:   https://pastebin.com/8CTM3Nkz

4 issues here:

1.) Your modpack needs more RAM. To run this modpack, you need atleast 128 GB RAM, it will run very slowly without that.

2.) Pack loads fine after kicking SAPManPak out of your modpack. Dunno what it was in there for. However:

3.) Now, it crashes due to the version of agricraft you included. Oh look at the name, that's a name commonly found on thirdparty crap rehost sites that steal downloads. Its so outdated that you can't even find that version anymore on the ACTUAL DOWNLOAD PAGE.

4.) Now it crashes due to Forestry being awfully outdated, people have moved on to Forestry 4.

After these updates, the pack finally fully loads again.

Cleanup: Remove legacyjavafixer, that fix has been included in Forge since around v1345. You are running 1614. Remove IGW, as it is empty. Fix the origin of BetterStorage, EyeMod, Grim3212 Core, his Pokeball mod, Morph and the Uncrafting Table.

Share this post


Link to post
Share on other sites
36 minutes ago, JaariAtmc said:

4 issues here:

1.) Your modpack needs more RAM. To run this modpack, you need atleast 128 GB RAM, it will run very slowly without that.

2.) Pack loads fine after kicking SAPManPak out of your modpack. Dunno what it was in there for. However:

3.) Now, it crashes due to the version of agricraft you included. Oh look at the name, that's a name commonly found on thirdparty crap rehost sites that steal downloads. Its so outdated that you can't even find that version anymore on the ACTUAL DOWNLOAD PAGE.

4.) Now it crashes due to Forestry being awfully outdated, people have moved on to Forestry 4.

After these updates, the pack finally fully loads again.

Cleanup: Remove legacyjavafixer, that fix has been included in Forge since around v1345. You are running 1614. Remove IGW, as it is empty. Fix the origin of BetterStorage, EyeMod, Grim3212 Core, his Pokeball mod, Morph and the Uncrafting Table.

Thank you :) I've updated forestry and agricraft, removed lagacyjavafixer and SAPManpack. But what do you mean by fix the origin of them? Thank you again :)

Share this post


Link to post
Share on other sites
3 hours ago, manikminer123 said:

But what do you mean by fix the origin of them? Thank you again :)

As in "Download these from either CurseForge or from the modmakers own website, and not from crappy thirdparty rehost sites." This would've prevented the agricraft issue, for example.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Similar Content

    • By Borby
      ing anything else... Help? 
    • By T6K_CHEWIE
      I followed the directions on how to create and publish a new modpack on the Technic Platform, but when I go to download it and play it there are no mods installed not even Forge. I don't understand what I did wrong, I even watched some YouTube videos on how to make and publish a modpack on Technic and followed their instructions, but nothing worked. Please let me know if you can help, I'd prefer it if someone called me on Discord so we could screen share, if not I understand just let me know what to provide to get the help I need. Thank you. My Discord is St.Nibba#6691.
    • By Caminon
      Whenever I try to run the sh in the server folder in the terminal, this happens:
      A problem occurred running the Server launcher.java.lang.reflect.InvocationTargetException
              at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
              at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
              at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
              at java.base/java.lang.reflect.Method.invoke(Method.java:564)
              at cpw.mods.fml.relauncher.ServerLaunchWrapper.run(ServerLaunchWrapper.java:48)
              at cpw.mods.fml.relauncher.ServerLaunchWrapper.main(ServerLaunchWrapper.java:17)
      Caused by: java.lang.ClassCastException: java.base/jdk.internal.loader.ClassLoaders$AppClassLoader cannot be cast to java.base/java.net.URLClassLoader
              at net.minecraft.launchwrapper.Launch.<init>(Launch.java:33)
              at net.minecraft.launchwrapper.Launch.main(Launch.java:27)
              ... 6 more

      I'm running on Debian, just installed java fresh on this computer. I can't seem to figure out why it won't work.
    • By LogDotAlpha
      So i made a modpack and did allt he steps right (i've made modpacks before) but when i try to start it the bar gets full, technic closes (here minecraft would start) and technic just opens againd. I give technic launcher 4GB of ram so that shoud not be the problem. Anyone that can help?
      Here is the log file:
      *wall of log removed*
       
    • By levelzyt
      Every time I try to join my Tekkit Legends server it crashes on the loading in screen. I have a crash report here (https://paste.ubuntu.com/p/DGXy74QZtY/)