• 0
Sign in to follow this  
havocx42

mod_IC2AdvancedMachines : Unsupported major.minor version 51.0

Question

It looks like the Tekkit 2.1 server is currently not compatible with the recommended version of java and requires Java 1.7

Update to Java 1.7 to fix this problem. Hopefully.

Java 1.7 can be found here. I'm not providing support for installing Java. I'm afraid you will have to figure that bit out yourself.

Also please ensure that if you have a 64bit OS you are using the 64 bit version of java.

Thanks to tradari for pointing this out.

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

I have the same problem, but I can't seem to get java 1.7 from my research

http://www.oracle.com/technetwork/java/javase/downloads/jdk-7u3-download-1501626.html

Accept the license agreement, then download whatever installer corresponds to your OS. Make sure if you're on a 64-bit system that you download 64-bit Java.

No, it doesn't matter that it's the JDK; it still has the JRE in it.

Share this post


Link to post
Share on other sites
  • 0

Well, there is the problem.. I have a mac, and there is no official release for it. I think

I have java 1.7 now but the problem is still there.

Share this post


Link to post
Share on other sites
  • 0

I've updated to Java 1.7 using the Windows x86 download (I'm running Vista on a 64-bit, I assumed this was the correct installation as when I install programs, they go to Program Filesx86), but when launching the server, I still get this error:

http://pastebin.com/29vyPW1j

Share this post


Link to post
Share on other sites
  • 0

:(

same here ive installed java 1.7 and i get the same error

EDIT I FOUND A FIX

i remembered when setting up the server it said to route system variable path to ;C:\Program Files\Java\jre6\bin

so i decided hey what the hell could go wrong and i changed it to ";C:\Program Files\Java\jre7\bin" since the old jre was 6 i simply changed it to 7

boom everything succesfully loaded

-------------

another problem appears!

when i load the server and try to go on it with tekkit it says the following mods are not loaded and it just lists every mod

Share this post


Link to post
Share on other sites
  • 0

@Secret

Your post helped me, I'll help you.

Open your client, hit the options button, choose "Select Build Manually" or something like that, and choose the latest build.

Should fix.

Thanks, broski.

Share this post


Link to post
Share on other sites
  • 0

@Secret

Your post helped me, I'll help you.

Open your client, hit the options button, choose "Select Build Manually" or something like that, and choose the latest build.

Should fix.

Thanks, broski.

synray, no problem man, and tanks so mcuh for helping me with my problem! it works i can play with my friends now.

*brofist*

Share this post


Link to post
Share on other sites
  • 0

If you install Java, it does not remove old versions. You can manually control the version it is using under Windows by going to the Control Panel and opening the Java icon there.

Go to the "Java" tab, then click "View..." (under Java Runtime Environment Settings). This will show the versions of Java installed to your machine. If you have some programs that still require a different version of Java, I would recommend not removing old versions, but instead controlling what applications use each. You can also simply uncheck Enabled for your old versions if you are unsure about removing them. Just make sure to leave the 1.7 version enabled for Minecraft's server.

Share this post


Link to post
Share on other sites
  • 0

The thing is, what if you have a mac, and you cant manually update it to java 1.7 because of the stupid software update which only does the rec build of java?

Share this post


Link to post
Share on other sites
  • 0

If you have Ubuntu OpenJDK 7 can be very hard to install, but it is possible, managed to get it in eventually using a custom PPA someone set up. Anyway, after you have gotten OpenJDK7 working you can still get a similar error, I did. The problem was with permissions in Linux, if you copy in files to your minecraft directory while in sudo and then run the server some of the files might be denied access. Make sure you are not in sudo when copying them to the folder and that usually fixes it. Just a tip.

Share this post


Link to post
Share on other sites
  • 0

So, i did everything recommended in this thread... updated to Jave 1.7, its the 64bit Version for my 64bit OS, it's the only Java version enabled, the Path Variable is set to the jre7 version, restarted several times, downloaded the server again, in case config files may have been changed when starting with errors...

But still exactly the same error stream, posted here before by many others...

Any other ideas?

Share this post


Link to post
Share on other sites
  • 0

For all of you whom are having problems even though you have Java 7, I have found a solution.

If you are running a 64 bit OS, don't install the x86 version. Install the x64. It's obvious, but people are still encountering these problems.

Hope this helped :)

Share this post


Link to post
Share on other sites
  • 0

For all of you whom are having problems even though you have Java 7, I have found a solution.

If you are running a 64 bit OS, don't install the x86 version. Install the x64. It's obvious, but people are still encountering these problems.

Hope this helped :)

sadly that is not a solution for me, because i did... i hope with the update tomorrow, maybe there will be a fix, even for the rest of us

Share this post


Link to post
Share on other sites
  • 0

:(

same here ive installed java 1.7 and i get the same error

EDIT I FOUND A FIX

i remembered when setting up the server it said to route system variable path to ;C:\Program Files\Java\jre6\bin

so i decided hey what the hell could go wrong and i changed it to ";C:\Program Files\Java\jre7\bin" since the old jre was 6 i simply changed it to 7

boom everything succesfully loaded

-------------

another problem appears!

when i load the server and try to go on it with tekkit it says the following mods are not loaded and it just lists every mod

I can't seem to figure out what you did, what file did you configure to get it to work?

Share this post


Link to post
Share on other sites
  • 0

:(

same here ive installed java 1.7 and i get the same error

EDIT I FOUND A FIX

i remembered when setting up the server it said to route system variable path to ;C:\Program Files\Java\jre6\bin

so i decided hey what the hell could go wrong and i changed it to ";C:\Program Files\Java\jre7\bin" since the old jre was 6 i simply changed it to 7

boom everything succesfully loaded

-------------

another problem appears!

when i load the server and try to go on it with tekkit it says the following mods are not loaded and it just lists every mod

were do i go to set up the jr7 bin thing in the server

Share this post


Link to post
Share on other sites
  • 0

So I am getting that same error

FINER: THROW

java.lang.UnsupportedClassVersionError: net/minecraft/server/mod_IC2AdvancedMachines : Unsupported major.minor version 51.0

The only way to fix this is if the server is running 64bit java version 7? I am trying to use this on a host, verygames.us and they allow 3 versions.. minecraft vanilla, craftbukkit, and openmod. I like to run things on openmod cause the craftbukkit version they have the craftbukkit.jar hidden or something, I tried renaming Tekkit.jar to craftbukkit and gave errors.

So, I just deleted the openMOD install, uploaded these files, started the server with Tekkit.jar and it loads everything fine except the IC2AdvancedMachines and I can not connect.

Is anyone else using verygames as their host and got this to work?

Share this post


Link to post
Share on other sites
  • 0

Hello, I have done everything that everyone says to do and it still comes up as the 51.0 error.. I use windows 7 64-bit and have the right version of Java for it. I used the sticky guide to make a server too.... Nothing seems to be working. Help?

Thanks.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this