Jump to content

How do I install Bukkit Plugins on Tekkit Server 1.0.6?

Recommended Posts

  • 4 weeks later...
  • 3 weeks later...

Hi everyone, I am new here and have a question about installing and running mods or plugins. A short bit of history and my mine craft experience level first. I have been using a vanilla Minecrat for almost a year. I then added Craftbukkit to it so I could use WorldEdit, which I thought was a very cool mod. I used it to build a redstone computer and a giant calculator - LOL. I kind of got board with the original minecraft and wanted to take it a step further. So after doing some research I found the tekkit version. I found some tutorials and setup a server on my computer, though I will be the only one using it. Just wanted to let everyone know where I stand in reguards to my Minecraft experience level. Before I start to explain my problem I want to point out that I have done some homework and know that certain versions should match. I have spend the last several days looking at websites and watching tutorials and trying different versions of mods to try to resolve my problem and have been unable to do so, which is why I am here.

I have the current launcher build installed - Build 253

I have the Tekkit server 1.0.6 installed

I have Modpack Tekkit version 1.0.6

Minecraft version 1.5.1 - MCP V7.44 - FML V5.1.43.679 - Forge - 67 Mods loaded and active

I also have MCPC-Plus-1.5.1-R0.3-SNAPSHOT-f682-400.jar - This is the last 1.5.1 version before 1.5.2 put out

I also have have LogMeIn Hamachi

I installed Single Player commands Mod 1.5.1 from http://seered.tv/single-player-commands/ and I followed the instruction on the website.

Not sure what other information you may need, but onto my problem. I can start my server and log into Minecraft single or multiplayer though single player is all I am interested in right now. Craftbukkit Mod seems to be working because I have access to all the resources and can set the time to day or night and turn on and off the rain.

What I cannot get working is the single player commands that I installed. I installed them manually with WinRAR. I moved all the MOD class files into the .minecraft/bin/minecraft.jar file and deleted the META-INF folder per website instructions. I then moved the WorldEdit.jar file into the .minecraft/bin folder.

When I run Minecraft the only thing that works is the Craftbukkit. When I try command //wand I get the command not found. When I try /help I only get the default 6 or 7 commands.

So I need to get the single play commands working so I can use WorldEdit.


Link to comment
Share on other sites

you may want to try installing the folders to the correct directory, .minecraft is vanilla, .technic\tekkitmain is where tekkit lives. Also in the future since your issue is not related to the OP, make your own thread.

Also if you are only playing SSP you really don't need the server files.

Link to comment
Share on other sites

I remember seeing this thread in a search I did a couple days ago and thought I would put it here. Thanks for the tip, I'll pay more attention to the topics next time.

I did not even think of putting the SPC in the .technic/tekkitmain folder. I'll have to try it. Thanks for the quick reply.

Well now I broke it. I did the same procedure but to the .technic/tekkitmain, and now Minecraft crashes. I am going to start a new thread.

Link to comment
Share on other sites

  • 2 weeks later...

  • Download MCPC+ here: http://ci.md-5.net/job/MCPC-Plus/ (pay close attention to which one you need, ver for 1.5.1)
  • Place in same folder as your Tekkit.jar
  • Change your batch/script to run the MCPC+ jar instead of your Tekkit.jar

Hey, I just upgraded my server to the latest version, and went into my batch file by right clicking then selecting edit, I changed the line

java -Xmx3G -Xms2G -jar Tekkit.jar nogui



java -Xmx3G -Xms2G -jar MCPC+.jar nogui


(i renamed the mcpc file to MCPC+ as it was a bunch of random letters and numbers so i could work easier)

It opens the MCPC+ file and does some loading then it crashes...

Any help here would be much appreciated... If someone could send me a like to a video or even make one that would be even more appreciated!

Many thanks,


Link to comment
Share on other sites

I'm just wondering why you're trying to run a server if your the only one that's going to be playing on it? Would be easier to just load a Single Player Tekkit game and be done?

Also, don't sign your post, may want to read the forum rules.

Link to comment
Share on other sites

Vivacity when I ran that it keeps coming up saying "This version of (every single core mod) does not support minecraft version 1.5.2

Remove it from your coremods folder and check here for updates"

Why is this so difficult? Is there no way to just download ONE MCPC+ version and just be done with it? The instance when it said This version of 'GalacticCraft1.5.1' (or whatever it said) check "Here" It took me to the Galacticcraft website and it said 'Download version 1.6.1 or get DEV builds" Apparently according to you im supposed to have 1.5.2 so i went into 'Dev builds' and it comes up with a completely blank page!

Can someone make a video or at least give me VERY detailed instructions on how to do this? Originally all i wanted to do was install a few plugins for my server which me, and about 10 mates will be playing on, although i want it setup like a professional server... (btw i use hamachi)

Link to comment
Share on other sites

its kinda like sarcasm but not really was meant to be funny

imo it was funny because on one hand i was commenting about the legality of highjacking a thread and then right after highjacking the thread

sorta like saying you shouldn't smoke with a cigarette hangin outta your mouth

Link to comment
Share on other sites

Well that fixed the server, says 'Done!' but I cannot check if it actually works because every time i open tekkit it just says 'Not Responding' and then comes up with a windows box saying 'Java Platform SE Binary not responding'... Which is kinda annoying :( restarted my laptop several times and it still does it...

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...