Jump to content

1.3.9 server installation issues


Recommended Posts

Hi there. Please bear with me, as I am fumbling around trying to update my server.

My server host is Treepuncher/Kerplunc. I rent a dedicated Technic Pack server. The modpacks all have one-click installation, and I have been pretty happy with them so far. Unfortunately, the latest version of Big Dig they offer is 1.2.2, and having played both "Space Tekkit" and Voltz, I naturally want to update to the latest recommended build. (1.3.9)

I am not the most computer literate person, but from what I understand, I need to delete and replace the old files on the server that correspond to the new files in the 1.3.9 server download. I get that, and I am able to transfer almost all the files except two: "launch" (windows batch file) and "launch.sh"

I am using Filezilla, and whenever I try to transfer either of these files, I get the following:

Command: STOR launch.bat

Response: 550 Permission denied.

Error: Critical file transfer error

Status: Disconnected from server

When I right click on either of these files and look at the properties, there is a message that says the file is from another computer and may be blocked etc., so I tried hitting "unblock" and "apply" and I still get the same error.

Is this because my server host won't allow it? Is there something I need to do to the files to get them to transfer successfully? I know I should probably contact the server host, but I have issues with that as well lol. (login for support is separate from actual server login and the email password changing process does not work for me...)

I am hoping someone here is knowledgable enough to help me. Why can't I download these files?

Thanks in advance for any advice you have to offer.

Link to comment
Share on other sites

  • 2 weeks later...

Big Dig 1.3.9 works on my server now. After a lot of back and forth with my server host's support, they offered to just do it for me, and i gladly accepted. The only issue now is how to get it back if I decide to switch modpacks again, so yeah, it would still be nice to know how to get the server to recognize that I want to play Big Dig. Specifically:

What file do I need to modify to get the server to recognize the modpack that I currently wish to run if I have other modpack's .jar files uploaded to the server in addition to Big Dig? Currently, I am too scared to touch anything because we FINALLY got this thing running after a week and a half. (I won't bore you with my whining lol.)

Also: which of the other files/folders in the Big Dig 1.3.9 download are essential to have on there? (i.e. coremods, mods etc.)

Also also: Thanks in advance for any help you provide. Sometimes, it's tough going for me because I don't really have much of a computer background other than learning some BASIC on Apple 2es in high school. (years ago, obviously.)

Link to comment
Share on other sites

I'm not sure how your host handles starting/stopping servers so I cant really help much. I can say "launch.bat" and "launch.sh" and Batch and Shell scripts respectively used to launch the server. Essentially they run the BigDig.jar file with certain command line arguments (Min and Max memory usage, no-gui) so they shouldn't really be needed.

I'd assume after uploading the files (everything EXCEPT the launch files is needed as far as I know.) there should be some way of telling your host which .jar to run for the server. You'd want to select BigDig.jar.

Of course you don't have to use every mod listed in the mod's/coremod's folder, however your members would have to remove those mods from their clients as well and you'd be in a whole new realm of complications.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...