Jump to content

I can't get tekkit working no matter what.


Recommended Posts

I have java 7 and every time i try and play any type of tekkit mod pack on my mac my it loads the mods and right when it closes out of the login screen and "fml" is setting up my game or whatever, fml closes first then the window. I've tried reinstalling java 7, trying all the mod packs, restarting my computer, deleting EVERYTHING tekkit and then redownloading and nothing seems to work! any help would be great! thanks!

Link to comment
Share on other sites

okay, so I guessed right; but I should have asked that first.

So that suggests you probably have the (very common) problem of a Java version that doesn't play nice with the LWJGL (that's the LightWeight Java Game Library). As it happens, you cannot run Java 7 on a Mac with the default LWJGL version. You would need to either downgrade to Java 6 (which likely means a complete Java uninstall followed by a Java 6 install) OR manually upgrade your install's LWJGL to 2.9 (I can't give you any help there, as I know very little about Macs).

to check your version, go to the Terminal and type "java -version"

The catch is that the Java 7 / LWJGL 2.9 combo seems to cause upside-down graphics unless you run in full screen. So keep that in mind when deciding upon a course of action. I'm sure a fix for LWJGL is in the works, but there's no telling how long it will take.

Link to comment
Share on other sites

Alright, so Imma spare u some time I've managed to copy the files from LWJGL when u download it and tried launching the game and it worked, only one little problem, the game is upside :P

I don't understand what he means by that or how he got the game running..? Do you have any advice? It worked for him it i just don't understand

Link to comment
Share on other sites

I really wish I had seen this before you went through all of the hassle of this. The fix is really easy.

1) Create a folder on your desktop and put your TechnicLauncher inside

2) Create a new text edit file and paste this into it

export JAVA_HOME=/System/Library/Frameworks/JavaVM.framework/Versions/1.6/Home

java -Xmx1024M -Xms1024M -jar ~/Desktop/[FILE NAME GOES HERE]/TechnicLauncher.jar

3) Make the file plaintext (Under format)

4) Save the file as TechnicRun.command

5) Open terminal and type

chmod a+x

Do not press enter

4) drag the TechnicRun.command file into the terminal and press return.


This solution evaded me for the longest time. Please please please pass it on to anyone else who is having problems with a mac. It is a hell of a lot easier than trying to downgrade java manually.

Hope this helps!

Link to comment
Share on other sites

I am having a similar problem on a Windows 7 Home Premium Acer V5-531. I get Tekkit uploaded and it freezes at the "Mojang" screen.

You are probably having a problem with a particular mod and not with the launcher. Once the Mojang screen has appeared you are into the mod pack.

Link to comment
Share on other sites

I did exactly what you said and the exact same thing is happening. I open the technic launcher console and it just crashes for no reason. No errors. Nothing. I've tried literally EVERYTHING to get tekkit working and it just wont.

Link to comment
Share on other sites

Hi Fido, this script worked for me. Thanks for posting.

Can you tell me how to get it to run on my son's user account please, on my MBP, OSx 10.8.4. He is a standard user, and when he launches the script, it errors out with "insufficient permissions". Using the "get info" right click action, authenticating as admin, and trying to set permissions doesn't work as there is no option for 'execute'.

Regards, Mat

Link to comment
Share on other sites

Actually, I sussed it using chmod. It appears 'get info' dosen't let you add 'execute' as a permission

Mats-MacBook-Pro:~ ed$ cd desktop

Mats-MacBook-Pro:desktop ed$ ls


Skypestart bukkit server

Mats-MacBook-Pro:desktop ed$ chmod 777 TechnicRun.command

Mats-MacBook-Pro:desktop ed$

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...