Jump to content

File Corruption? Possible Fix?


Recommended Posts

Posted Today, 06:04 AM

Recently after trying to curb some lag with a computer restart i exited out of my save world to the minecraft load screen, but not out of the technic launcher. After restarting i was able to click play on Tekkit, open up the minecraft load screen but when i clicked on my save world it would exit out of the minecraft launcher and bring me back to the Technic launcher. I tested this out with another world, did the same restart, and the failure to load was the same. I also copied the save file to another computer with the same failure in not loading concluding that something in the save was messed up. I copied the crash report below. Is there anything specifically wrong with the save? Is there anyway ti can be recovered? Thank you for all the help you can provide.


---- Minecraft Crash Report ----
// This doesn't make any sense!
Time: 2/22/14 10:48 PM
Description: Exception in server tick loop
at StevenDimDoors.mod_pocketDim.core.PocketManager.createAndRegisterBlacklist(PocketManager.java:697)
at StevenDimDoors.mod_pocketDim.saving.DDSaveHandler.loadAll(DDSaveHandler.java:61)
at StevenDimDoors.mod_pocketDim.core.PocketManager.loadInternal(PocketManager.java:436)
at StevenDimDoors.mod_pocketDim.core.PocketManager.load(PocketManager.java:263)
at StevenDimDoors.mod_pocketDim.EventHookContainer.onWorldLoad(EventHookContainer.java:130)
at net.minecraftforge.event.ASMEventHandler_47_EventHookContainer_onWorldLoad_Load.invoke(.dynamic)
at net.minecraftforge.event.ASMEventHandler.invoke(ASMEventHandler.java:39)
at net.minecraftforge.event.EventBus.post(EventBus.java:108)
at net.minecraft.server.integrated.IntegratedServer.func_71247_a(IntegratedServer.java:85)
at net.minecraft.server.integrated.IntegratedServer.func_71197_b(IntegratedServer.java:107)
at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:445)
at net.minecraft.server.ThreadMinecraftServer.run(SourceFile:583)


Link to comment
Share on other sites

Go into your main tekkit folder and find the most recent forge log, likely named ForgeModLoader-client 0 and open it, after a crash. scroll to the bottom of that log and from there, scroll up until you find the first error after the last line about sending event  FMLServerAboutToStartEvent, it'll likely be right after a line that looks like this:

[INFO] [STDOUT] Loading Dimensional Doors save data...

Or at least it will be if I'm right... I had the same error last night after my computer crashed and corrupted some stuff, but managed to recover it. oh and there will be time and date stamps in that line too of course.

Edited by rogueclon946
Link to comment
Share on other sites

  • 3 weeks later...

It crashes when it's trying to load the first dimension. I get the 

[INFO] [STDOUT] Loading Dimensional Doors save data...

And the crash as stated above immediately afterwards.


Alright, I just fixed my server, at the expense of any warp doors that were set up.


I move the Dimensional Doors Folder out of the World folder (backing it up) and then started the server. Seems to be working fine. Will report back when I try to make a warp door again.

Edited by brilliantjoe
Link to comment
Share on other sites

I had the same issue, in my case the first problem occurred when trying to read in the DimensionalDoors blacklist.txt file (world/DimensionalDoors/data/blacklist.txt).  It had written out as an empty file somehow (possibly in a power outage shutdown), and it needed to contain just an empty array... I just added


to the txt file, and that got me through that error.  Unfortunately, I then got another error from loading a DimensionalDoors data file, at which point I just shortcutted and restored the whole world folder to a backup from about an hour before the crash.


Overall, it seems like DimensionalDoors save data can be pretty thoroughly corrupted - I'm not sure whether it was just the timing of an outage coming right in the middle of the file IO (not much to do about it in that case other than put this box on my UPS) or if DimensionalDoors save data is just handled in such a way that it does not recover from an unexpected stoppage.

Link to comment
Share on other sites

What sel mentioned is one of the issues I had before. The other option is to go into the dimensionaldoors folder in your save, go into data, and look for any files that list a dimension and are completely empty. Delete that file(s) then go back and delete the entire folder(s) for the matching dimension(s). That was what worked for me.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...