Jump to content

Java Problems - Maximum Heap size


SirIkaros
 Share

Recommended Posts

So I just wanted to set up a server to play with my friend some Attack of the B-Team but then this showed up in the launch.batch window:
 

 
C:UsersFabiDesktopNeuer Ordner (2)>java -Xmx3G -Xms2G -jar BTeam.jar nogui
Picked up _JAVA_OPTIONS: -Xincgc -Xms2048m -Xmx4096m
Invalid maximum heap size: -Xmx4096m
The specified size exceeds the maximum representable size.
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.
 
C:UsersFabiDesktopNeuer Ordner (2)>pause


ignore the german words in the path

Does someone know what is going on here ?
I already tried to add the PATH and CLASSPATH way to my enviromental system but that also hadn't worked.
Link to comment
Share on other sites

Post your issue on the tracker after reading the guidelines, check signature for these links.

 

Edit: Btw, quick note about this issue is that _JAVA_OPTIONS is a environment variable like PATH and CLASSPATH but is used to add default options to java being ran. this can be edited where you first went to look at adding PATH and CLASSPATH

Edited by Kalbintion
Link to comment
Share on other sites

It's most likely one of two things, you either have less than 4GB of RAM, or your default Java virtual machine isn't the 64-bit version.  If you have 64-bit windows, you can fix this easily by uninstalling all JAVA instances, then reinstalling 32-bit Java, and then 64-bit Java.  Doing this will allow IE11 to work properly with sites that use Java, and will make the last one you installed the system VM (64-bit.)

 

Alternatively, if you have 64-bit java, you can run it directly from "C:Program FilesJavajre#binjava.exe" replacing the # symbol with either 7 or 8 depending on which version you have installed, so you'd just replace the "java" part in the batch file with that entire string, including the quotes.

 

If you have less than 4GB of RAM, you need to edit the environment or check the Java control panel iin order to change the values you have entered.  The environment can be edited through the System control panel icon, then (With Windows 7) Advanced System Settings..., and there's a button called environment variables.  The VM options in the Java applet are under the "Java" tab, and then click on View...  The column is labeled Runtime Parameters (At least with Java 8.)

Link to comment
Share on other sites

This however isn't an issue with the mod pack, nor a bug, it's completely a client side configuration problem, and any information regarding the set up or installation of the mod pack should be in this forum, easy for people to access.  With as many problems with people not using the right Java version, or not having 64-bit Java installed, I'm surprised there isn't already a sticky tutorial to help that.

Link to comment
Share on other sites

Refer to the pinned topic at '?do=embed' frameborder='0' data-embedContent>> in regards to what I mean about that.

 

It specifically states to report any issues and bugs to the tracker, this includes an incorrect java version.

 

Also the reason this issue is reported so often is that most people do not know how to read the logs or know what version of java they have. It is often difficult to expect everyone to know this type of information.

Edited by Kalbintion
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...