planetguy

[1.7.10] Remain in Motion - Continuation of Redstone in Motion

Recommended Posts

Can you add please some integration with OpenComputers?
For example, push an event(signal) every time, the carriage moves. Because there is no other way to know, if carriage is already done moving, or not.

Share this post


Link to post
Share on other sites

Hardcore mode still does not consume energy in 1.2.0. energyStored fills but does not drain with motion. Using config:

 

####################
# Hardmode
####################

Hardmode {
    B:"Hardmode is activated"=true
    I:"Power capacity of carriages"=10000
    D:"Power consumption factor"=100.0
}
 

Share this post


Link to post
Share on other sites

Congrats to 1.7! Great work.

Few things...

I cant see carriages in motion.(movement) They simple disappear until they are on place.

Template carriage does not have right click "ghost" view.

Share this post


Link to post
Share on other sites

I cant see carriages in motion.(movement) They simple disappear until they are on place.

Template carriage does not have right click "ghost" view.

The network handling is still broken, but I'm trying to fix it. I rushed to get a 1.7 port out because it's been so long, but there are still a few issues to work on. Another one is carriages will move through existing blocks.

Share this post


Link to post
Share on other sites

Network handling is fixed (meaning carriages' fancy rendering works) and the new build is up. There's a bug with carriages being perfectly happy to move through blocks.

 

I'd recommend staying on 1.6 for now, unless you're dying to play with the new 1.7 stuff.

Edited by planetguy

Share this post


Link to post
Share on other sites

well thanks anyway ive made a script of my own to tide me over the idea was to have several monitors on different levels to call the elevator but for now im just using some wireless redstone controllers

Share this post


Link to post
Share on other sites

Noticed since updating (on 1.6 version, still waiting for other mods to update to 1.7), that translocators wont work if they are adjacent to more than one frame block. I may be wrong but I dont think this was previously the case. Anyway, not sure if its feature or bug but it breaks the compactness of some of my designs...

 

Any help much appreciated :)

Share this post


Link to post
Share on other sites

IIRC that's how it's always worked, only one carriage can be moved at a time by each moving machine (engine, motor, translocator, or transduplicator). I can hopefully change that, but not for a bit over a week, since I'm traveling.

Share this post


Link to post
Share on other sites

Fair enough, after checking I realise it has always been like this. For some reason I thought translocators could only move the block on top, so they'd ignore the other sides... Anyway, what would be great would be if engines etc. ignored carriages whose facing sides were closed, or, even better, if the sides on the engine/translocator itself could be toggled (as this would also allow for template carriages).

 

An another note, do you ever intend to make it so that translocators display their label visually on the block itself? (would be very helpful though not sure how it would work on ones with multiple colours...)

Share this post


Link to post
Share on other sites

Translocators are supposed to display the colours on their side, in the form of some tiny icons in the black square. It was planned to switch recolouring over to a GUI system, but I didn't get around to it yet.

Edited by planetguy

Share this post


Link to post
Share on other sites

There seems to be a tick rate bug when ever I move the frame controller with a button. It crashes after use. here's the crash log.

 

http://pastebin.com/hsBGRRjk

Thanks for the error report. I can't look into it now since I'm traveling, but it looks like the way Redstone in Motion moved scheduled ticks might be broken.

Share this post


Link to post
Share on other sites

Thank you for forking and working on this, planetguy. This is fantastic!

 

I have one question concerning 1.7.2 though: With ThermalExpansion/cofh not being updated to 1.7.2 yet, what mod do you suggest to use in order to have a source of power and transportation of RF?

Share this post


Link to post
Share on other sites

Have you tried Mekanism? I think their Universal Cables will do the job just fine.

Share this post


Link to post
Share on other sites

Have you tried Mekanism? I think their Universal Cables will do the job just fine.

Wow, I didn't know that one yet. Thanks! But are you sure it's on 1.7.2 yet? I can't seem to find a corresponding download link, and what I'd consider the authoritative source doesn't explicitly state what version it runs on...

Share this post


Link to post
Share on other sites

No idea. Universal Electricity all together may be holding off release until every mod is up to 1.7.2.

 

But do keep it in mind, of course--it's a good alternative.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.