Jump to content

Cant get my Classic Tekkit Server working


Recommended Posts

I have installed the 3.1.2 classic tekkit server from the classic tekkit page but it doesn't work. When i go into the "launch.bat" folder, it comes up with:  

C:UsersNameDesktopTekkit Server>java -Xmx3G -Xms2G -jar Tekkit.jar nogui

'java' is not recognized as an internal or external command,

operable program or batch file.

 

C:UsersNameDesktopTekkit Server>pause

Press any key to continue . . .

 

That's what it says, and when i press and key it just quits so i cant get my server to turn on!!!

 

help me please!!! :) Thank you

Link to comment
Share on other sites

Thank you but i don't know what to add the PATH????? And to i have to add it to the variable name or the variable value???

I havent had any experience with using java only using it for being able to play MC.

So if you could help me more that would be greatly appreciated :)

Link to comment
Share on other sites

I'm happy to answer questions, but I'm not sure where you are stuck.

 

The link I provided (above) has instructions for various operating systems.  When you follow those instructions, where do you get stuck?

 

On my system, I look for "Path" under "System Variables", click "Edit...", scroll to the end of the list, then add a semicolon followed by the directory path I shared above.  You'll have to verify the specific location of your java bin file on your own system.  You'll find it somewhere in program files, java/jre7/bin (or whatever version you have).

Link to comment
Share on other sites

But i dont know where to write it. i do everything but i dont have a list when i click on PATH, it comes with Variable name: PATH then Variable Value 

Ps i am on a windows 8 btw

 

And i dont understand the java link that well 2. I get stuck at part 6

Edited by Amourax
Link to comment
Share on other sites

Well i tried it and it doesnt work so i am not doing it properly. This is what i did: I add ;C:Program Files (86x)Javajre7 . i added this to the variable vaule but when i went into command promt it did that same the same thing, it closed :(

Link to comment
Share on other sites

well, I'm guessing you need something more like

;C:Program FIles (86x)/Java/jre7/bin

 

Sorry if I mistakenly described the path you need.  Also, just making sure, you should verify that is where your 'java.exe' file is located.  I probably should have been more specific about that as well.

Link to comment
Share on other sites

Then I'm guessing you have the wrong path.

 

Did you verify that there is java.exe in that folder?  Double-check the folder name and path.  If possible, include a screenshot of the folder that contains java.exe just in case I can spot something.

Link to comment
Share on other sites

last thing I can think of, in case of a typo...  go to your jre7/bin folder and right-click on java.exe.  Select "Properties" and then copy/paste the exact line from the pat listed under Location.  Of course, you'll still need a semicolon at the front.

 

If that doesn't work, then I guess we need to find somebody else with another solution.

 

Maybe try posting over here, where there's more server-operator traffic:  http://forums.technicpack.net/forum/50-server-op-swap-shop/

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...