Jump to content

Deployer Difference

Recommended Posts

Hi Folks,

OK ... I created a potion engine. Part of which was, a four square of water. One of the sides was a deployer. When the deployer had an empty glass bottle in it, and the deployer was fired, the bottle filled with water.

Now, since the update, when the deployer receives a pulse, the bottle just vanishes.

The only difference is that I've changed the direction in the new engine, instead of being fed from the right and extracted from the left, it is now fed from the left and extracted to the right.

The working version is 2min 40 secs in this video - https://www.youtube.com/watch?v=kluTwzrHVkw

Link to comment
Share on other sites

As the deployer acts as an inventory, the directions should not affect the pulling of items to/from it. I attempted to recreate your issue but it seems to be working on my end; perhaps a screenshot to better understand the situation?

Deployers recreate a right-click action, and it the functionality of bottles has not changed; my only thought would be a rouge rogue retriever pulling the bottles out somehow.

EDIT: Fixed a typo that made me sound prejudice. I do dislike red though.

Link to comment
Share on other sites

I'll get a screen shot up tonight as I'm on ADSL and am currently uploading a video, but I tried again with no extra gear, just a four square of perpetual water, surrounded by marble block, and two deployers on one side. Simply loading them with glass bottles and giving them a redstone signal, resulted in the bottles vanishing from the deployers.

In case it makes a difference, the world was converted up to the latest.

I tried it again just now and the result was the same. The bottles vanish. The server logs have no events to report.

Link to comment
Share on other sites

Went through the log file after reboot, these are the things that stood out to me...



2012-06-23 06:56:19 [WARNING] Configuration for mod_ComputerCraft.enableAPI_http found value 0 outside acceptable range 4.9E-324,1.7976931348623157E308

2012-06-23 06:56:19 [FINEST] Configuration for mod_ComputerCraft.enableAPI_http found values default: 0, configured: 0, interpreted: null

2012-06-23 06:56:19 [FINEST] Configuration for mod_ComputerCraft.modem_range found values default: 64, configured: 64, interpreted: 64

2012-06-23 06:56:19 [FINEST] Configuration for mod_ComputerCraft.modem_rangeDuringStorm found values default: 1, configured: 16, interpreted: 16

2012-06-23 06:56:19 [FINEST] Configuration for mod_ComputerCraft.modem_rangeDuringStorm value set to: 16

2012-06-23 06:56:19 [FINE] Configuration for mod_ComputerCraft written to mod_ComputerCraft.cfg

2012-06-23 06:56:19 [iNFO] Loading ComputerCraft: To change block IDs, modify config/mod_ComputerCraft.cfg

2012-06-23 06:56:19 [iNFO] ComputerCraft: computerBlockID 207

2012-06-23 06:56:19 [iNFO] ComputerCraft: diskDriveBlockID 208

2012-06-23 06:56:19 [iNFO] ComputerCraft: diskItemID 4000

2012-06-23 06:56:19 [iNFO] Adding Material: 207:X207

2012-06-23 06:56:19 [iNFO] CONFLICT @ -49

2012-06-23 06:56:19 [iNFO] ComputerCraft: Searching for RedPowerLib...

2012-06-23 06:56:19 [iNFO] ComputerCraft: RedPowerLib and methods located.

2012-06-23 06:56:19 [iNFO] Adding Material: 208:X208

2012-06-23 06:56:19 [iNFO] CONFLICT @ -48

2012-06-23 06:56:19 [iNFO] Adding Material: 4256:X4256

2012-06-23 06:56:19 [FINER] Pre-initializing /home/data/l2jserver/tekkit2/mods/CraftingTable3_1.8.jar

2012-06-23 06:56:19 [FINE] Reading existing configuration file for mod_CraftingTableIII : mod_CraftingTableIII.cfg

2012-06-23 06:56:19 [FINEST] Configuration for mod_CraftingTableIII.blockIDCraftingTableIII found values default: 126, configured: 126, interpreted: 12





2012-06-23 06:56:21 [FINE] Sorted mod list [codechickencore-server-0.5.2-bukkit-mcpc-1.2.5.zip, wrcbe-core-server-1.2.1-bukkit-mcpc-1.2.5.zip, buildcra

ft-2.2.14-mcpc1.2.5-r6.zip, redpower-all-2.0p5b2-mcpc1.2.5-r2.zip, buildcraft-2.2.14-mcpc1.2.5-r6.zip, AdditionalPipes-2.1.3-MCPC1.2.5-r3.zip, industri

alcraft2-1.95b-mcpc1.2.5-pre1.zip, mod_IC2NuclearControl-1.1.6-mcpc1.2.5-r3.zip, buildcraft-2.2.14-mcpc1.2.5-r6.zip, buildcraft-2.2.14-mcpc1.2.5-r6.zip

, redpower-all-2.0p5b2-mcpc1.2.5-r2.zip, redpower-all-2.0p5b2-mcpc1.2.5-r2.zip, redpower-all-2.0p5b2-mcpc1.2.5-r2.zip, redpower-all-2.0p5b2-mcpc1.2.5-r

2.zip, redpower-all-2.0p5b2-mcpc1.2.5-r2.zip, server, wrcbe-addons-server-1.2.1-bukkit-mcpc-1.2.5.zip, CraftingTable3_1.8.jar, notenoughitems-server-1.

2.1-bukkit-mcpc-1.2.5.zip, zimmibis-core48.2.1-tubestuff-48.2.1-mcpc1.2.5-r1.zip, Railcraft-5.2.4-MCPC-1.2.5-R1.zip, server, enderstorage-server-1.1.1-

bukkit-mcpc-1.2.5.zip, zimmibis-core48.2.1-tubestuff-48.2.1-mcpc1.2.5-r1.zip, wrcbe-redpower-server-, EE2ServerV1.4.5.1-bu

kkit-mcpc-1.2.5-r2.zip, advancedMachines_4.0_bukkit.zip, redpower-all-2.0p5b2-mcpc1.2.5-r2.zip, mod_ironchests-server-, T

ekkit2.jar, mod_compactsolars-server-, mod_NetherOres.jar, buildcraft-2.2.14-mcpc1.2.5-r6.zip, PowerConverters-1.3.4-mcpc7

8-r1 (1).zip, mod_chargingbench-server-1.95b-mcpc1.2.5-r1.zip]




2012-06-23 06:56:22 [iNFO] Adding Material: 223:X223

2012-06-23 06:56:22 [iNFO] Adding Material: 219:X219

2012-06-23 06:56:22 [iNFO] CONFLICT @ -37

2012-06-23 06:56:22 [iNFO] Adding Material: 226:X226

2012-06-23 06:56:22 [iNFO] CONFLICT @ -30

2012-06-23 06:56:22 [iNFO] Adding Material: 245:X245

2012-06-23 06:56:22 [iNFO] Adding Material: 244:X244

2012-06-23 06:56:22 [iNFO] Adding Material: 225:X225

2012-06-23 06:56:22 [iNFO] Adding Material: 239:X239

2012-06-23 06:56:22 [iNFO] CONFLICT @ -17

2012-06-23 06:56:22 [iNFO] Adding Material: 237:X237

2012-06-23 06:56:22 [iNFO] CONFLICT @ -19

2012-06-23 06:56:22 [iNFO] Adding Material: 236:X236

2012-06-23 06:56:22 [iNFO] CONFLICT @ -20

2012-06-23 06:56:22 [iNFO] Adding Material: 238:X238

2012-06-23 06:56:22 [iNFO] CONFLICT @ -18

2012-06-23 06:56:22 [iNFO] Adding Material: 218:X218

2012-06-23 06:56:22 [iNFO] Adding Material: 217:X217




2012-06-23 06:56:22 [FINER] Initializing mod_CraftingTableIII

2012-06-23 06:56:22 [FINER] Initializing mod_NotEnoughItems

2012-06-23 06:56:22 [iNFO] CONFLICT @ -204

2012-06-23 06:56:22 [FINER] Initializing mod_TubeStuff

2012-06-23 06:56:22 [iNFO] Adding Material: 194:X194

2012-06-23 06:56:22 [FINER] Initializing mod_Railcraft

2012-06-23 06:56:23 [iNFO] Adding Material: 7315:X7315




2012-06-23 06:56:23 [FINER] Initializing mod_EnderStorage

2012-06-23 06:56:23 [iNFO] Adding Material: 178:X178

2012-06-23 06:56:23 [iNFO] CONFLICT @ -78

2012-06-23 06:56:23 [iNFO] Adding Material: 7493:X7493




2012-06-23 06:56:23 [iNFO] mod_TubeStuff: BC Energy doesn't seem to be installed

2012-06-23 06:56:23 [FINER] Post-initializing mod_Railcraft

2012-06-23 06:56:23 [FINER] Post-initializing mod_CCTurtle

2012-06-23 06:56:23 [iNFO] ComputerCraft: turtleBlockID 216

2012-06-23 06:56:23 [iNFO] Adding Material: 216:X216

2012-06-23 06:56:23 [iNFO] CONFLICT @ -40




2012-06-23 06:56:24 [iNFO] This server is running CraftBukkit version git-Bukkit-jenkins-CraftBukkit-98 (MC: 1.2.5) (Implementing API version 1.2.5-R1.





2012-06-23 06:56:24 [WARNING] Could not get information about this CraftBukkit version; perhaps you are running a custom one?: FileNotFoundException

2012-06-23 06:56:24 [iNFO] Preparing start region for level 0 (Seed: 1793606941451300184)

2012-06-23 06:56:25 [iNFO] Removed Badly Synced node at:275,60,98 on 101 in dim0

2012-06-23 06:56:25 [iNFO] Preparing spawn area: 44%

2012-06-23 06:56:26 [iNFO] Preparing start region for level 1 (Seed: 1793606941451300184)

2012-06-23 06:56:26 [iNFO] Preparing spawn area: 8%

2012-06-23 06:56:27 [iNFO] Preparing spawn area: 77%

2012-06-23 06:56:28 [iNFO] Preparing start region for level 2 (Seed: 1793606941451300184)

2012-06-23 06:56:28 [iNFO] Preparing spawn area: 56%

2012-06-23 06:56:29 [iNFO] Server permissions file permissions.yml is empty, ignoring it

2012-06-23 06:56:29 [iNFO] Done (4.942s)! For help, type "help" or "?"

Link to comment
Share on other sites

I'm not sure if this has any bearing, but when I filled a bottle manually, (from a cauldron) it jumped out of my hand (I was only holding the one) and it came back in to my inventory as if I had just acquired it from floating on the floor. I think that is its normal behaviour, but I can't be certain.

I tried the same thing filling the water bottle from a water source (the four square of water) and it stayed in the same inventory slot, ie. it stayed in my hand.

I also tried putting an already filled watter bottle in the deployer and triggered it ... the water bottle stayed there and didn't vanish.

Link to comment
Share on other sites

I'm asking myself questions. One of them is this - if the recommended action is to start a new world on a major update, then what is the chance of this happening again?

I look at friends videos where they have worlds running for more than a year on vanilla, and all their buildings and inventions carry forward with them.

Now ... I know that the modders put in one heck of a lot of effort ... and I greatly appreciate it. Putting this many mods all together, and the technical innovation and coding that must go in to things is stunning; and I'm perfectly willing to send a few dollars to the modders on an irregular basis as I can afford it ...

However, I don't want to have to abandon my worlds with major releases.

If things like this aren't picked up, and no one can help, then these problems render an awful lot of time and effort to be wasted.

I'd really like to hear the opinions of the devs on this, because I have a very, very tough decision to make ... whether to stay with Tekkit (which I enjoy considerably) or move back to vanilla.

Link to comment
Share on other sites

It's there. I had to remove it last time Tekkit updated. Best way to get rid of it is to just go into the mods folder and remove it. You're going to want to get rid of the invtweaks file. That'll make the mod inoperable and it won't load.

Link to comment
Share on other sites

Great. Now when you say it vanishes, does it just pop out onto the floor, or just up and completely disappears? I'm wondering if sticking a chest next to it might give it a place to go. I know it's a stupid longshot and it's probably more a matter of bug in the coding when dealing with bottles (most likely due to Mojang code), but worth a try to get your machine working.

Link to comment
Share on other sites

A good idea.

I tried it, but they up and vanish completely. Chests at either side, but none of them collected a bottle. They also didn't end up near the water, either.

One thing I'm going to try is lowering the water in relation to the deployer and see if that helps.

Nope - the bottles stayed in the deployer, but didn't fill with water.

Link to comment
Share on other sites

  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...