• 0
TechnicPissingMeOff

Can you fix your launcher please?

Question

So 2 days ago i downloaded, and played Crazy Craft on the Technic Launcher. Played fine, i got off, and now today i want to play again. After having to download the installer which for some reason is the only way to launch the Application (nice going), i finally tried to play Crazy Craft again. I click "Play" and bam some message is telling me I'm only using 1gb of ram. So i knew how to fix this, just go to the Java settings in the Launcher and allocate some ram. When i had played 2 days ago i had allocated 6gb of Ram. And now the maximum is only 1gb. After about an hour of googling I'm very lost. Some people said you don't have the right version of Java, or some bs like that. Well it worked 2 days ago and i haven't done anything since to even slightly mess with Java. So if you could fix your launcher so i can play, or just make it so you don't have to select an amount of ram to bestow upon the modpacks that would be great. I honestly don't even know why there's not already an option to say "Hey i have a nice computer, use as much ram as you need so i can play the modpack with 60 fps baby."

I'd add pictures to prove i have java, but there's a "max total size" of 0.49MB. Text files easily get bigger than that lmao. And it won't let you add in imgur links either :)!

Also i can allocate 7gb of ram in the Curse Launcher so yeah.

Edited by TechnicPissingMeOff

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

This is a PEBKAC issue.
1) If you saved the downloaded file, you wouldn't need to download it again. The "installer" is the launcher.
2) Somehow you managed to uninstall your 64 bit Java and installed 32 bit.
Actually 2) Are you still on the same computer? No, seriously. Are you? All your issues seem to stem from not being on the same computer as the first time.
 

 

"Hey i have a nice computer, use as much ram as you need so i can play the modpack with 60 fps baby."

That's actually a horrible thing, because Minecraft is incredibly bad at using RAM. The more RAM you allocate, the more RAM Minecraft can use, the more RAM it needs to clean... which Minecraft is bad at. This mean you're going to lag to shit.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By xSypho
      Hello, I have recently found a glitch where technic launcher will not open. I run it, but it does not create a .technic folder or open. Minecraft works perfectly fine and I found out it was something to do with java. I have tried reinstalling java and restarting my computer, virus scans, reinstalling technic, but nothing works. I'm running Windows 7 64 bit if it helps. Thanks. (Ill attach the java errors) Here's the text information. The program mmc.exe version 6.1.7601.23892 stopped interacting with Windows and was closed. To see if more information about the problem is available, check the problem history in the Action Center control panel.
       Process ID: 1e50
       Start Time: 01d47e0a62f4ddd3
       Termination Time: 22
       Application Path: C:\windows\system32\mmc.exe
       Report Id: b8dfe13d-e9fd-11e8-a761-4c72b9081cf7
      The picture of it is attached.

    • By bootleg_engineer
      Hi! Im trying to run the modpack craft & slash rpg, but it won't even get to the loading screen. it stops at:
      [B#395]  [19:14:45] [main/WARN] [FML]: The coremod codechicken.core.launch.CodeChickenCorePlugin does not have a MCVersion annotation, it may cause issues with this version of Minecraft
      I dont even get a crash log or anything. Ive tried all versions of java 8 and java 7, testing my ram and removing the only faulty stick in the system, reinstalling java, reinstalling the modpack, reinstalling the launcher, and even wiping the modpacks folder in appdata.
      I doubt this will help, but here's the log for the technic launcher console: https://pastebin.com/ex6qY5JA
    • By mariossi255
      Hi, a friend of mine wanted to make a server where him and his followers could kill some time with both premium and sp clients.
      Sometimes this comes up when trying to launch the mod (with the sp launcher), and it usually 'fixes' itself by restarting it a couple of times.
       
       
       
       
      But when they manage to get past that and connect to the server, they can be seen by others but this covers their game window
       
    • By Danny84
      Hello,
      I'm having trouble getting Tekkit Legends to launch. When I click "play" in the launcher, it validates all the files, but then just goes back to the launcher as if nothing had happened. Here is the log. I have tried resetting the modpack multiple times, to no avail. I am able to launch vanilla through the technic launcher, but not tekkit legends.
      Any help is much appreciated!
    • By Kehlani
      The bug:
      Type of bug: Launcher bug. Reproduction rate: 10/10. Technic launcher keeps crashing on me when I'm in-game due to low memory. It also does lag a decent amount.
      Shader/Resource pack:
      I use shaders and an x32 pixel resource pack. I have the same setup in vanilla Minecraft and it works fine there. Technic will still crash even without a resource pack and shader.
      The issue in detail:
      I can't allocate more than 1gb of memory in the java settings in the technic launcher. I have tried to go to advanced system settings in system and checking out the environment variables. I cannot find "_JAVA_OPTIONS" in there. I can find "C:\Program Files (x86)\Common Files\Oracle\Java\javapath" in the system variables but that's it when it comes to java. I just downloaded technic launcher again after a long time (around 2 years). It used to work fine and I used to be able to allocate way more ram (I believe I used 4GB back then). Technic launcher is updated. My draw distance within minecraft is set to 8. 
      OS and Java version:
      I have an x64 bit operating system. I also have java downloaded for an x64 bit operating system. I have confirmed this by running vanilla Minecraft (not technic) and putting my view distance to far. According to this post  https://goo.gl/bpK4qw , if I had x34 bit java installed it would just give me an error message but that does not happen with me. I have also made sure to download the x64 bit version of java and I have updated it.
      ALL INFORMATION ABOUT COMPUTER SPECS + OS + LOGS + MC 
      System specs:  https://imgur.com/a/ryE71LV
      250gb SSD (60gb free space) + 2TB HDD (650gb free space) (I run technic from my HDD). 750W PSU. Windows and my graphics card driver is updated.
      LOG: I tried pasting the log into paste.ubuntu and pastebin but the log is too large and my browser can't handle it (the file size is 25MB). I pasted quite a bit of the end of the log. Sorry but that's the best I can do here and hopefully, it will provide some information of importance: https://paste.ubuntu.com/p/ZFGmBvcqh2/